HL7800 firmware update problem

We are experiencing problems when updating HL7800 using the “on click” HL7800-M. on Y-modem mode.

We see some “Ymodem: too many transmission attemps”, and “Failed to send block - retrying part. X tries remaining”.
And then the upgrade application just stops, sometimes on retry 10, sometimes on retry 19, but never gets to the last retry, it kind of gets stuck.

This just happens on some PCs while on others it goes fine, we are kind of assuming is PC dependent, but if so, are there any sierra “com port” drivers that we need to use?

Are you using Win10?

if you are using win7, you can see here:

Thanks for the response. I am using w10 on both PCs
I can access the ATI port, that works fine, and the FW download starts but gets stuck on in the middle.

Do you have some usb 1.1 hub to force slow speed?

Nope, on both PCs I am using the same USB3.0 hub

You can try usb2.0 and see if this is related to speed

I used now a USB2.0, same result, maybe it went further on the download, but stuck in on of the “writing to flash”

And got an error

seems the error is different and it can go further.
Is it 100% failure on this particular PC?

It happens on all new batch of PCs.
After the last try, the HL78 keeps rebooting all the time, so now I have 2 boards down

is that you must use USB to upgrade?
How about UART?

Also tried, same result

then how about the local upgrade by +WFWUPD with XMODEM?

Unfortunately local upgrade is not an option

what baud rate are you using for UART?

Now the HL is constantly rebooting, I can see the bootloader port, then the application ports, and reboots. Now working with the previous PC, on which I am able to do successful upgrades, If I am able to engage the HL78 when in bootloader, I can do an upgrade, but stills rebooting forever…

do you have uart0 in your board?

Yes I have UART0, but disabled it using at+kusbcomp to enable USB. And I am not sending anything to that uart (from the host I mean)

Do you see anything coming out in uart0?
Can you upgrade via uart0?

Nothing comes out UART0. I cannot upgrade using that uart as attached to the host