HL7800 FW upgrade fail


I use Linux to upgrade HL7800 FW.
Using sft to upgrade FW will fail.
What is the problem?
Could anyone help with advice.

does it work with UART port instead of USB

Hi @jyijyi

It only work with USB-UART 0 port.
We tried USB-UART 1, RS232-UART 1 and main USB on the HL development board and it didn’t work either.
We also tried using the HL FW .exe file provided by the Sierra source on Windows. Also unable to successfully upgrade FW.

I don’t see problem to upgrade in Windows via UART1 which is the AT command port, this should be very basic stuff

What is the error on UART1 when upgrading?

UART upgrade FW failed as shown below.

We also tried to use the main USB to upgrade the FW but failed as well.
The .sh file in SFT needs to set the ttyCAM port.
ttyACM0=AT port, ttyACM1 should be set as SFP_LOGGER by AT command?

For the screenshot of UART upgrade failed, it can download at the beginning, but failed in the middle, not sure if this is some hardware issue.
Can you try in Windows and see if it works?

Yes, it works on Windows.
I can find the bootloader port when restarting the module.
So I can set AT port and Bootloader port in HL7800. file.

then maybe it has some serial communication problem with linux as you don’t see problem in Windows