HL7845 firmware upgrade to fails

Hi, we recently bought HL7845 module and successfully attached it to HL78 development kit. Currently, HL7845 has firmware version 5.4.5. When trying to upgrade to the most recent, the upgrade process fails with “Information - ExecuteScript: EXIT(1)! Unrecognized or Unsupported device”. Does this happen because direct upgrade from 5.4.5 to 5.4.10 is not supported? Or could there be some other issues? I have followed the instructions in ‘HL78 Series - Firmware Update Methods - Rev2.0’ and tried using both UART1 and USB.

Thanks for any help,

Hi @olli.apilo,

Welcome to our community!

Could you please take a look at the below question/concern and share your answers?

  1. When you plug in the device to the computer, did the computer recognize the port? Could you please share a screenshot with me?
  2. Are you using the One-click .exe file to update the firmware? Could you kindly provide the full log fail when updating the device?
  3. Have you tried upgrading through other methods? For example: FOTA or Local firmware download.


Thanks for the reply,

Yes, I’m trying to do the FW update using the one-click method. I tried to attach the FW update logs and the screenshot from Device Manager, but the forum denies it “Sorry, new users can not upload attachments.” Anyway, I have attached the relevant lines from the logs below (sorry for the long post). I feel that this is not a port driver issue because the AT commands through UART1 work fine.

I have found only the one-click SW package for HL7845 from the Sierra support page, so maybe the local delta download is not feasible here? Currently I cannot try FOTA due to some issues in our core network, but that can also be tried later.


ImageBurnTool Log File
20/04/2023 16.04.17

Image Burn Tool for SWI HL78xx
(c) Sierra Wireless, Inc. All rights reserved - Version 500.20.7 Build 2022/06/02-08.29.00

20-04-2023 16.04.17, Information - GetUBootVersion: uBootVersion file=ALT1250_03_02_00_12_15041_UB

20-04-2023 16.04.17, Information - AdditionalSettingsForUartBurning: Catching device …
20-04-2023 16.04.20, Information - AdditionalSettingsForUartBurning: Setting baudrate to 3000000

20-04-2023 16.04.20, Information - AdditionalSettingsForUartBurning: Setting flow control off

20-04-2023 16.04.20, Information - BurnFirstPhase: Log file’s location:‘C:\Users\admin\AppData\Local\Temp\HL7845.’

20-04-2023 16.04.20, Information - BurnFirstPhase: Starting burning phase
20-04-2023 16.04.20, Information - StartBurningPhase: Catching device …
20-04-2023 16.04.20, Information - StartBurningPhase: Verifying selected bank …
20-04-2023 16.04.20, Information - PreBurnValidateAndProcess: Verifying correlation between burning layout and board type:
20-04-2023 16.04.20, Information - PreBurnValidateAndProcess: Device’s response: # hwflow off
RTS/CTS hardware flow control: off



20-04-2023 16.04.20, Information - PreBurnValidateAndProcess: Chip type (ALT1250-SB-E0) correlates to burning layout
20-04-2023 16.04.21, Information - PreBurnValidateAndProcess: Verifying device type …
20-04-2023 16.04.21, Information - PreBurnValidateAndProcess: printenv mtdparts

20-04-2023 16.04.21, Information - PreBurnValidateAndProcess: device type in use: alt12xx_sflash
20-04-2023 16.04.21, Information - PreBurnValidateAndProcess: Verifying device compatibility to selected version …
20-04-2023 16.04.21, Information - PreBurnValidateAndProcess: Verifying device partitions size …
20-04-2023 16.04.21, Information - BurnFirstPhase: Building scripts for first phase …
20-04-2023 16.04.21, Information - BuildScriptForFirstPhase: Script added: C:\Users\admin\AppData\Local\Temp\7zS45149622\RK_03_02_00\Scripts\sysHeader.altscr
20-04-2023 16.04.21, Information - BuildScriptForFirstPhase: Script added: C:\Users\admin\AppData\Local\Temp\7zS45149622\RK_03_02_00\Scripts\uboot.altscr
20-04-2023 16.04.21, Information - BuildScriptForFirstPhase: Script added: C:\Users\admin\AppData\Local\Temp\7zS45149622\RK_03_02_00\Scripts\config_record.altscr
20-04-2023 16.04.21, Information - BuildScriptForFirstPhase: Script added: C:\Users\admin\AppData\Local\Temp\7zS45149622\RK_03_02_00\Scripts\map.altscr
20-04-2023 16.04.21, Information - StartBurningPhase: Script for first phase: -
20-04-2023 16.04.21, Information - BurnFirstPhase: Verifying images existence …
20-04-2023 16.04.21, Information - StartBurnSession: Starting burning …
20-04-2023 16.04.21, Information - StartBurnSession: Reading Session File: -
20-04-2023 16.04.21, Information - StartBurnSession: Processing burning script …
20-04-2023 16.04.21, Information - IfCondCommand: Exit @true code=1
20-04-2023 16.04.21, Information - ExecuteScript: @line=if true exit 1 “Unrecognized or Unsupported device”
20-04-2023 16.04.21, Information - ExecuteScript:
Unrecognized or Unsupported device

20-04-2023 16.04.21, Information - RestoreValuesForUartBurning: Restoring baudrate to 115200

20-04-2023 16.04.21, Information - ReopenDeviceInDefaultBaudrate: Catching device …
20-04-2023 16.04.22, Information - WrapupUartBurnProcess: Resetting device …
Completion Time: 04-20-2023 4.04.22 pm

HL7845. (195.5 KB)

Any update or advice to this issue?

The forum now allows me to be upload attachments. Please find the requested screenshot and the log files attached.

I also tried the FOTA update method via the AirVantage platform. Unfortunately, it seems that HL7845 is not supported in AirVantage. When I try to register our device, it is not possible to select HL7845 as ‘Type’. There are some other HL78xx modules but not HL7845 available.

Best regards,

Hi @olli.apilo,

Please refer to the method for updating firmware using Linux One-click


HL7845. (610 Bytes)


Unfortunately I’m having the same issue with the Linux One-click FW upgrade as in HL7812 firmware upgrade fails immediately on linux - #2 by jerdung, i.e. the process fails before any actual connection to HL7845. Please find the log file attached. No *dl.log file was generated.

I’m running Ubuntu 20.04.6 LTS with the following steps:

  1. Give access rights to /dev/ttyUSB0 (UART1)
  2. Test that AT command interface is working fine.
  3. Try to install mono-runtime. Unfortunately no mono-runtime installer can be found from Sierra Source.
  4. Install mono-complete following the instructions from Download - Stable | Mono
  5. Verify that installation was successful by entering mono --version
  6. Try to run the one-click FW file by entering SFXTERM=0 DL_PORT=ttyUSB0 DL_BAUD=3000000 ./HL7845.

My guess is that the problem is that there is no ~/mono-runtime folder due to different procedure on installing mono. It would be great if the file mono-runtime-x86_64-installer mentioned in the FW upgrade instructions could be made available. Or optionally, I would be grateful for some instructions on how to configure mono to be compatible with HL7845. I have to admit that I’m a complete newbie with mono.


Hi @olli.apilo,

If you have followed the instructions to update the HL7845 firmware correctly but the issue still persists, in this case, it would be better to send an email to technical support at support@sierrawireless.com for assistance.



OK, then it seems that I’m stuck here because “This email address is only used for responding to existing Support Cases.” and we don’t have Sierra support contract. Does Sierra have any repository for older firmware releases? My guess is that it’s not possible to directly upgrade from 5.4.5 to 5.4.10. I could try with an older FW package.

Best regards,