EM7750s are "Turned Off" every reboot ever since 1903

We have about 60 Panasonic CF53s with EM7750s that we are trying to upgrade to Windows 10 1903, but after the upgrade the modules show as “Turned Off” every time the system boots. The only way to get them to turn back on is to flip the hardware WiFi switch on the machines off and back on again.

I called Panasonic and they told me it was a Sierra Wireless issue and there was nothing they could do.

I have the latest USB Drivers (Build 4836) and firmware for the card (3.5.10.13). Has anyone experienced this before and managed to resolve it? We are no longer legally allowed to keep these machines running 1809 because of security purposes, so not upgrading to 1903 is not an option.

1 Like

I am having exactly the same issue. I installed 1903 initial, but then dropped down to an earlier version to verify what OP stated is indeed correct. Is there any communications between Microsoft and Sierra Wireless to fix this issue?

1 Like

We have exactly the same issue using MC7304 and MC7430 modules. The problem isn’t limited to Sierra Wireless devices either, we’ve experienced the exact same issue using Quectel modules.

It’s a Windows 1903 issue - that still isn’t resolved. With Microsoft forcing 1903 on all users this month, it’s going to be an even bigger problem.

1 Like

Same issue with EM7565 and 1903. After toggling Airplane mode it works fine. As a workaround I have implemented a script that toggles Airplane mode on the module itself when Windows boots or returns from sleep. Has there been any update from Sierra on this?

1 Like

same problem with my mc7710, even in win10 1909, but it works fine in 1809, so this is a bug undoubtedly!

1 Like

Same results for me also in 1909. EM7565 still not working until Airplane mode toggle.

1 Like

Any one can help to solve this problem?

Would love to hear if there has been a fix too. Have the same problem and seen the same issue on multiple boards.

1 Like

we having same issue with mc7354 and mc7455. i already submit my request to Microsoft but i did not get any reply yet.

@mboyer your script sounds like the perfect work around for now. Do you perhaps have a code sample or could point me in the right direction to implement the same solution?
Thank you

@jimbo.ctra I ended up finding a way to update the module that has been working for my team. The process is here. I had my team using a sled as they were updating a large number of units, but you can follow the same process on a module that is installed in a device. Hope that works for you!

Okay maybe give this a try:
at!entercnd=“A710”
at!udusbcomp=8

@mboyer @tomato
Thank you! I’ll give it a shot soon. What are these commands actually doing to overcome the Windows 10 issue?
Thanks

@jimbo.ctra @tomato
ATE command displays characters typed
AT!ENTERCND=“A710” is password unlock command
AT!USBCOMP=1,3,100D is setting the config index, type, and interface, which we are setting to MBIM in this step
AT!RESET is resetting the module for the new settings to take

Couple of notes:

  • I tried this with Putty and it failed, but works fine with Tera Term.

  • This specific command is for the EM7565. We also had to configure some EM7455 and you have to use these settings in step 7: AT!USBCOMP=1,1,100D

I believe the AT!USBCOMP=8 opens up additional COM ports, I didn’t use that command in my script

Good luck!

MC7750 was launched back then to mainly support Windows 7 in QMI mode. The AT commands will set the module to use MBIM mode instead of QMI. Hopefully that will make the communication between the WWAN module and 1903 build well synced up as Windows 10 version 1903 seems to have caused some radio state sync up issue.

Note that AT!USBCOMP command only works for EM74xx/EM75xx product families. Legacy products should use AT!UDUSBCOMP

In normal or working case you should see both hardware and software radio state to be on as showed below.
c:>netsh mbn show radio int=*
Radio state information for interface Cellular 1:

Hardware radio state     : On
Software radio state      : On

When WWAN showed as “Turned Off” issue happens, one of the radio state must have been set to Off. Even though customers may have not changed any of the radio states at all. Possible solutions are listed below:

  • Toggle the hardware Wireless switch (Some platform may have a hardware switch and others may use Fn Key
  • Toggle Airplane mode in Settings --> Network & Internet. You can try toggle the Cellular software switch as well
  • Restart computer
  • Check with platform vendor for BIOS/EC update

@mboyer @tomato
These instructions were incredibly helpful, thank you. Our MC7430 modules are back online with the setting AT!USBCOMP=1,1,100D

Hopefully Sierra/Windows fixes this in the near future so the work around is unnecessary but at least we have something for now. Thank you

MC7750 here with the same issue. I am unable to run the AT!USBCOMP command no matter how i try to run it.

As explained in an early response, the legacy products such as MC7700 and MC7750 use AT!UDUSBCOMP instead of AT!USBCOMP command.

i have an mc7750 and tried this using : AT!UDUSBCOMP=1,1,100D ALL I GET IS ERROR? HAVING THE SAME ISSUES AS THE POST. WINDOWS 10 PRO 1909 BUILD.

TYPED : AT!UDUSBCOMP? — !UDUSBCOMP: 6 IS WHAT I GET BACK