MC7304 - Windows 10 issue


we have problems with MC7304 cards installed in Panasonic Toughbooks. Since Win10 update 1903, there is the issue with the mobile connection.

After Windows starts, the status of the mobile connection is “Turned off” and the mobile switch button does not react. The name of the operator is displayed correctly and the internet access works. So there is the issue, that Windows says “no internet connection” nevertheless connection works.

The only way to show status correctlly is switch the airplane mode on and than switch it back off. After that the mobile connection get status “Connected” and the mobile switch button begin works. Until next shutdown / restart / sleep.

This issue is present on all commputers with Windows 10 1903+. Before this update, everything worked fine.

All drivers and updates are up to date.
I tried clean installation, but w/o luck.

I am experiencing a similar problem with EM7455 in a Nuvo-7006LP from OnLogic. I am running Windows 10 Pro 1909. I have also tried a clean install. I am running the latest drivers from Sierra Wireless:

Interestingly, in Device Manger -> Network Adapters there are two listings for the Sierra Wireless:
Sierra Wireless Snapdragon X7 LTE-A WWAN Network Adapter
Sierra Wireless Snapdragon X7 LTE-A WWAN Network Adapter #2

…and when I look click on the network icon in the task bar there are two listing for the modem (Verizon Wireless). I can get one to list as connected while the other is always disconnected, however, I have no internet connection.

Images of the dual network adapters (there is only one EM7455 installed)

Cellular connection with two entries:


it’s a bug for win10, the only thing we can do is waiting, although half year has past.

Exactly same happens with HP 2560p/2570p’s and Sierra modules (windows 10 build 1903-1909) (MC8355)

hurry up and wait. not the best when it mission critical. I guess reverting back to 1803-1809 if that is possible.

In 1809 all works perfect…but you need to reinstall all the OS (It’s absurd to make this If you manage 20+ laptops…). This needs a fix!

Here you have same related bug:

Hope anyone can help to solve this bug. It last more than half years.