EM 7455 not working on my laptop

Hello, recently I installed an EM7455 on my ThinkPad yoga 260 laptop, running windows 10 64 bit, latest version. Windows 10 detected the device and I installed Skylight, but it’s still not working properly.

(The picture said that “ChinaTelecom” and “Turned off”. I tried to click and enable it, it doesn’t work.
QQ截图20200711195331 Skylight shows that “In the airplane mode, the wireless has been turned off” “The wireless function of this laptop has been turned off” My laptop is not in airplane mode.
I have tried to reinstall the driver, reboot the device, and reset the network setting of the laptop but these doesn’t work too. I have checked the frequency band and confirmed the EM7455 support the network that I am trying to connect. Please help.
Best regards.

What is the return of the following AT command?


Thank you for your reply, but I am a little confused because I am not professional in this region. May I ask more details about “AT command” where should I run it or where can I find more details about it?

Do you see modem port in device manager?

Hello, is this the port number? I can find it in Device manager

Something like this one

Thank you for your help.
This is my screenshot. Please take a look.

This is the screenshot under the General tab. But the manufacture is “Microsoft” not “Sierra Wireless Incorporated” Device status showed “This device is working properly”.

The second picture is under the advanced tab, the “Selective Suspend” value is “Enabled”

The last picture is under the “Power Management” tab, I have already canceled “Allow the computer to turn off this device to save power.” After a reboot, this device is still not working.
Best Regards.

Seems this is not the modem port …
Do you see Device Manager> Modems> Snapdragon ???

Thank you for your reply. I think this is the Snapdragon modem.

This is not modem port for AT command, it is just network interface.

I just tried with my MC7430(FW :SWI9X30C_02.30.03.00_00) with WIN8, in case rmnet port in AT!USBCOMP is disabled, the skylight cannot communicate with module.
I need to set AT!USBCOMP=1,1,10D and then reset the modem, now the skylight can detect the module.