EM7455 / DW5811E - Device not detected

I was hoping to get some help with our Dell 7470 laptops with EM7455 air cards. We are having a few issues with this setup.

First after waking the machine up from sleep, or sometimes after a reboot, the skylight software will get stuck in a loop of “Mobile Broadband device not detected” and “Device detected”. If you continuously put the computer to sleep and wake it, or just keep restarting it, eventually it fixes itself and can be used again. During this time you will see the device appearing and disappearing in the device manager. Other times you will just see the device listed under ports as “DW5811e Snapdragon™ X7 LTE QDLoader Port (COM7)”.

To give a little more background information, we use Win 7 Enterprise. We configure 1 machine with all of our software and then use ghost to drop that image onto our other machines. We have 100 of this model machine and all of them experience this issue when we drop our image. I was wondering if maybe there was a setting that needed to be removed or setup before grabbing the image or anything anyone else can think of.

We have grabbed our image without the skylight software and air card drivers installed and with it installed. This does not change anything. It is broken on both. Also these are setup and imaged the same as our older 7440 / 7450 Dell laptops that have the EM7355/DW5808E air cards and we have never had a problem with those machines. I have tried all variations of drivers and skylight versions available from Dells website as well as requesting assistance from Dell, which has not resulted in anything that works.

These machines are setup with both Verizon and ATT service. The issue is present on both.

Please let me know what other information may be useful to you.

Hi,

Have a good day. I’ve MC7455 and EM7455 installed on DELL 7240 and LENOVO X220/X220T running Windows Pro 10 64 bit with latest sierra QMI drivers and skylight software. If you could see that “QDLoader Port” that means that module was brought up at “boot and hole” mode and waiting for firmware flashing. Have you tried install that module on hardware running linux or Ubuntu ? Because if already at “QDLoader Port”, by current sierra windows firmware flash tool (fdt.exe) this situation couldn’t be resolved and can be resolved through linux/ubuntu environment using Sierra QDI SDK or third party tool (qmi-firmware-update).

I have not tried running Linux or Ubuntu. I can simply restart the laptop or put it to sleep and wake it up and it will resolve itself. I’m just trying to find out what may be causing it to randomly get stuck in that mode and refuse to work without a few restarts or sleeps. On Friday I modified one of the cards to think it’s a generic sierra device instead of dell device and installed the latest drivers from Sierra and it still appears to be having these issues.

Hi,

I believe you’ve installed that DELL specific module and no #pins were taped. Because I’ve an experience where at 1st place #pin 8 were taped on EM7455 and installed on LENOVO X220/X220T running Win 7 PRO 64bit and upgraded to Win 10 PRO 64bit where that module was intermittently not recognized. This situation was resolved by remove that taping. Have you tried install latest firmware for that module ? Sometimes that problem were resolved by firmware flashing. I’ve another two (2) MC7455 modules and configured as (1,1,50D and 1,1,100D) for “ATI!USBCOMP” and installed on DELL E7240 running Windows 10 PRO 64bit and installed with latest Sierra drivers and “skylight” where so far no issues. Could you provide “AT!PRIID” of that module ? My one for MC7455 module as below:

at!priid?
PRI Part Number: 9906491
Revision: 001.001
Customer: Generic-M2M

Carrier PRI: 9999999_9904594_SWI9X30C_02.20.03.00_00_ATT_002.020_000
Carrier PRI: 9999999_9904609_SWI9X30C_02.24.03.00_00_GENERIC_002.021_000
Carrier PRI: 9999999_9904779_SWI9X30C_02.20.03.22_00_SPRINT_002.020_000
Carrier PRI: INTERNAL_9901234_EM7455_00.00.00.00_00_OEMPRI918_001.000_000
Carrier PRI: 9999999_9904780_SWI9X30C_02.20.03.22_00_VERIZON_002.026_001

OK
at!usbcomp?
Config Index: 1
Config Type: 1 (Generic)
Interface bitmask: 0000050D (diag,nmea,modem,rmnet0,rmnet1)

Thanks for the information Zainol. After further testing, it appears a piece of software on the machines is what was causing the driver to disappear and/or try to update the firmware randomly and fail. The software was NetMotion Diagnostics. After removing this the air card does not disappear and reappear at all and is not getting stuck during firmware update. It completes successfully.

The issue at hand now is randomly disconnecting after 5-10 minutes of being connected. I am not getting more than 2-3 bars in my area on either ATT or Verizon currently. When I went outside with the machines to test they pull 3-4 bars but the connection still drops after the same 5-10 minute period. I have since rolled back to a previous build of both skylight and the drivers from Dell to continue testing.

Did you ever resolve this issue? We have a similar issue where if we leave the computer for a few minutes, or someone logs out of Windows, the WAN card seems to disconnect from the network. Users aren’t able to authenticate with our domain controller. I can’t find any power saving settings to keep the card on at all times either. Any help would be appreciated.