Em7455 WAS working but now it stopped

computer crashed everything was working fine, then when windows and dell updated, compter restarted and no internet, then i started downloading all FW packs one by one, with verizon pack it will say disconnected, then i found US cellular pack got it to connect, but i had to install the pack everytime i restarted my computer to get it to connect. and now it just plain wont connect, and skylight is stuck on “firmware update” how do i fix this, sad cause it worked before, then works now for a little and now doesn’t work at all

dell precsision 7730 running windows 11 workstation

Do you still have the modem port in device manager?
what is the return of the followings?


hi, i went to device manager and copied this

Device USB\VID_413C&PID_81B6&MI_0c\6&12a50652&0&000c was configured.

Driver Name: netwmbclass.inf
Class Guid: {4d36e972-e325-11ce-bfc1-08002be10318}
Driver Date: 05/21/2024
Driver Version: 10.0.22621.3672
Driver Provider: Microsoft
Driver Section: wmbclass.ndi
Driver Rank: 0xFF2003
Matching Device Id: USB\Class_02&SubClass_0e&Prot_00
Outranked Drivers:
Device Updated: false
Parent Device: USB\VID_413C&PID_81B6\5&123eb065&0&18

is this correct? sorry not sure how to find the other information


Seems the driver cannot be run

Maybe i can uninstall and reinstall the drivers and try again?

I don’t know, you need to try whatever method to make the driver installed

Bump! any ideas, use this computer for business

you can see here for the dw58 driver:

i appreciate that, tried this also no luck, dw 5819 mine is dw 5811…crazy, it was just working and then not. i dont remember having to do this much trouible shooting in the past. wonder what im missing

when i do the verizon FW carrier pack it shows disconnected. where i was using US cellular just last night and it worked, now i flash US cellular and it says “no service”

says this, but when i click “connect” nothing connects, just get an error “ding sound” and i only get this far with verizon FW pack

does it work in Linux?

Hard to debug without AT command port…

how do i get the at command port? i have windows, not sure if it works in linux

you can see here:

You can install vmware linux in your windows

i appreciate your help, i am not versed in getting this AT, i tried to follow the page in the forum you described, if anything im now more confused, i downloaded tera term, but in that link you posted (and i read it now about 5x) and i couldn’t find where on earth to input anything to get this AT readout. i tried typing in tera term and it wont even let me type in the box. i’m so damn frustrated (not your fault) that this thing worked flawless before and into last night. this is a money making computer for my business, we do in field quotes on jobsites, etc. that needs this access to the internet. im so bummed, i tried calling Sierra wireless and they told me to kick rocks.

you might need to try linux to see if there is AT port

1 Like

yes, i could try that but even if i do linux in a virtual machine, i still have no idea how to get the AT port info so i can give you that. unfortunatly without step by step instructions i have no idea what im looking for, i tried installing and reinstalling drivers, even rolling back my windows updates, nothing, it was working just yesterday with the US cellular FW pack

you can install ubuntu 18 and install the MBPL USB driver: