*** xmodem error ***


#1

Hellow,

i’ve got a new Board with a Wavecom Q2686G and Firmware R73_00gg
I’m programming and downloading with M2M Studio 1.0
I can connect to hardware without problems, to my AT-Commands it replays correct.

But if i try to download a new application (UART 1), it reports *** XMODEM ERROR *** and i have to shut off the cpu for several minutes bevor i can work again.

Any idea what the Problem can be?
Power Supply ?

Reset is on (high)
ON/OFF CPU is High
Boot is open (<Problem?)


#2

Hi fakulatus

This error is normally received when we do not use the protocol as XModem or 1KX Modem while downloading the application… Also make sure you gave the “AT+WDWL” AT command before downloading the appli … :smiley:

hope this helps… :unamused:
Cheers,
Paruthiv


#3

I tryed but failed :frowning:

don’t think that’s the Problem…

i do the same download prosedure as i’ve done with the wavecom demoboard…

Actually, i think it’s a boot-Problem or a power supply problem, i’ve got a bit more than 300mVpp because of the RS232-Transceivers (ADM3307) and with no idea how to eliminate it (allready patched a lot of C in) :imp:


#4

Why is the boot pin high ???

Boot pin should be on while downloading the firmware… Boot pin should be OFF while downloading an application…


#5

i leave the boot-pin open, not connected to high or low

All data recive the wavecom well, but the q2686 don’t answer to the data-blocks (and begin to consume >100mA)…


#6

use of the BOOT pin is only required when using WDLWIN.
you can load firmware and application into the processor with AT+WDWL. regardless of the BOOT-PIN setting.


#7

The Boot-Pin was not the problem,
Problem was an undefinited output of the wavecom which disabled the Transreciver…

The only Problem left are the Trace, it still doesn’t work :frowning:


#8

What do you mean by this…??

See if the AT commands are working correctly then ideally “AT+WDWL” command should also work correctly. Try changing the firmware… and check what is the downloader version by giving "AT+WDWL? … the downloader could be corrupted…

is the problem seen with only one application … I mean have you tried downloading a sample aplication first say “Hello World” …???


#9

Everything’s fine now.

I had the enable of the transreciver on an “undefined by reset”-pin, so it toggled during the download of the Firmware