Corrupted Software


#1

Hello,

I have a Q2686. I have downloaded an application to the wireless CPU. When I executed AT+WOPEN=1 something strange ocurred:
-The Charger Led (red one) and the Flash-Led (green one) start blinking very quik. In the “Product Technical Specification” of Q2686 says that it means that the software downloaded is either corrupted or noncompatible.
But the problem is that I can’t communicate with the CPU. The AT commands doesn’t have response. I tried AT+WDWL but I have no response. The reset do nothing. I power off the supply but when I power on the situation is the same (the leds doesn’t stop blinking).
Maybe if I use the DWLWIN for downloading a new application, but I think that it cannot connect with the target.
What can I do to stop the leds and establish communiction with the Wavecom CPU?

Thanks


#2

I fear the DWLwin is your last chance to correct the module.

Did you already try it? Don’t think just try it. :wink:


#3

Hello,

I have downloaded the DWLWin from the Wavecom Website and installed it in my PC. I downloaded a new application in the wireless CPU and I have solved the problems of communication with the CPU!!! :smiley: Now I can communicate with the CPU, I have response to the AT commands that I send.

Thanks tomalex.