Why not register to the network


#1

Why not register to the gsm network


#2

Hiya,

Is your SIM card inserted properly (and the catch slid into position if using a Fastrack Supreme)? Do you have a PIN set on your SIM card?

Does the SIM work in a normal mobile phone?

ciao, Dave


#3

Does it work if you use a “normal” terminal emulator like Hyperterminal…?


#4

Thank you for your answer,
My SIM CARD works in normal mobil phone direct (no Pin Code) and i tried with hyper terminal but AT+CREG=0,0 hence not register to the gsm network.


#5

If you pay attention to pictures register to GPRS network only it can’t register to GSM network.


#6

Yes, I noticed that.

It’s very strange: I didn’t think it was possible to be GPRS registered without first being GSM registered - which is why I asked if this might just be a quirk of the Expresso interface…

Are you using a custom board?


#7

i don’t use custom board yet. I am new learning wavecom products.


#8

So what are you using?

The more information you provide, the more likely you are to get a useful reply!


#9

İ am using Fastrack Supreme 20 in Q2687H

R74_00gg.Q2687H 2120060 041709 19:18


#10

Have you tried other SIMs in that fastrack?

Can you try that SIM in other devices (other than your phone and that fastrack)?

Have you spoken to your Distributor about this?


#11

yes i tried another sim card but same problem continues and this sim card works another device. DAMNED! :angry:


#12

So the problem is associated with this particular Fastrack - so you really should be talking to the supplier about that!


#13

Hiya,

Have you slid the latch across the SIM holder on the Fastrack Supreme? Inserting the card is not enough…the latch has to be slid closed (i.e. over the SIM card) before the modem will recognize that there is a SIM card present.

ciao, Dave


#14

Indeed - but would it be possible for the Fastrack to be GPRS registered if it didn’t think it had a SIM?? :confused:


#15

Hiya,

Hmm, probably not. Although, it depends on what Expresso means by GPRS: Full Service.
If all that means is that the Internet plug-in is enabled (i.e. AT+WCFM=5 returns the appropriate result), then yes, I guess you could say that there is full GPRS service available to the application
This sounds like a question for the Expresso dev’s.

ciao, Dave


#16

Indeed - which is why I asked what hyperterminal (or another “real” terminal program) says…

To the OP: What response do you get from AT+CGREG? :question:


#17

Hiya,

Another check is to see if the red led on the Fastrack Supreme is flashing or solid on. If the led’s flashing, then the modem thinks that it has connected to the GSM network…

ciao, Dave


#18

Thank you for yor interest.
I told my distributor, will send a new one.


#19

A quick and easy way to know whether it is an Expresso issue or whether the problem is due to your Fastrack, would be to execute the AT Command directly from the AT Console :

Launch AT+CREG? command to get the GSM Registration status. In your case, the response +CREG: 0,0 indicates indeed that you are not registered.
Launch AT+CGREG? command to get the GPRS Registration status. In your case, the response +CGREG: 0,1 would indicates a successful registration.


#20

Hey there,

check the CGCLASS of the device. It can be either B,CG or CC. As i see, you have the “CG” Class activated, that deactivates the GSM Service.

Use: AT+CGCLASS=“B”
Sayonara