Fastrack Supreme 10 fails to detect SIM


#1

I have recently purchased a Wavecom Fastrack Supreme 10.
Before inserting the SIM, I contacted its company(Vodafone) to activate its GPRS service. I inserted it in the socket
just as I saw in the user guide:
1)With the pins on the upper side
2)The cut on the way in and right
3)Heard the click after inserting it
4)Moved the carrier towards the center to lock it.

I tested in Windows XP and HyperTerminal. It responded fine with most AT commands but the command AT+CPIN? returns
+CME ERROR: 10(entered AT+CMEE=1 to show error code) so it can’t detect the SIM for some reason.
I reset the modem with AT+CFUN=1 and returned:

+WIND: 3
+WIND: 14
+WIND: 0
+WIND: 7

Can you please help what I have to do to insert the pin and register the modem in the network?
I also noticed something when I installed M2M studio. The serial link manager doesn’t detect the modem in the serial port it’s connected(COM1). It says “Unable to open this COM(maybe already used: please select another COM)”.
Because I’m on the early stages of learning my modem, I’m using mostly HyperTerminal to test it with AT commands. Can’t I use simultaneously the M2M studio?


#2

Hiya,

Have you tried a different SIM in your module? Have you tried the SIM in another phone or modem? Maybe the SIM you have is damaged.

No, you can’t use M2M studio Target Management Perspective and another serial port at the same time. M2M Studio uses some of the advanced multiplexing features to sumultaneously provide access to both the debug traces and the AT command line - and will lock the COM port while the target is connected. Hyperterm does this as well - most (if not all) serial terminal applications require exclusive use of the serial port they are connected to.

There is no reason why you can’t edit code in M2M Studio and use Hyperterm to connect to the modem - just don’t hit the ‘Connect’ button in the Target Management Perspective…

ciao, Dave


#3

You’re right: There should be no reason - but M2MStudio does hog the serial port even when it isn’t connected! :open_mouth: :angry:

See: viewtopic.php?f=78&t=3813&p=14837&hilit=hog#p14837


#4

Hiya,

Oops, my bad.

However, if you open M2M studio you will get the little SELIMA icon in the task bar (next to the clock in Win XP). If you open that by double clicking on it, you can then close the COM port while leaving M2M studio running.

Just don’t try to connect to the device from the Target Management Perspective while you have SELIMA closed…

Works on M2M studio 1.0.2

ciao, Dave


#5

you can also use MuxConfTool (included in pre-m2m-studio SDK’s)
that way you can debug via TMT and/or M2M studio, use hyperterminal to do stuff, and even have it connected as a modem :stuck_out_tongue: