Fastrack Supreme 20 Firmware Upgrade


I hope someone can help me with this. I just tried to upgrade de firmware to the latest version in my Fastrack Supreme 20 wm20452. It has the 6.63 firmware version so I followed the process through the migration package exactly how its explained on the wavecom´s web page. I upload the file dwl for the q2687 wireless cpu from the migration kit and the one from the firmware release 7.4.

The problem is that the modem doesnt register to the network anymore. The LED doesnt blink anymore, its always on. The response to the AT+CREG? command its (0,2). When I power cycle the modem I get this wind outputs:

+WIND: 13
+WIND: 1
+WIND: 16
+WIND: 4
+WIND: 10,“SM”,0,“FD”,0,“ON”,0,“SN”,1,“EN”,0
+WIND: 11,“B160292BF4E5819F3E4B511FA8A01A36”,“DB1772147C722D07009512B00BEFE704”,“22E5BC5AF8BA2166069B0B1D0DDA9B70”

Anyone knows what could be the problem? What should I do to correct it? The firmware version was the right for my modem or I should had use another file? Will my modem work again?

I tried the firmware upgrade to use the M2M studio that I just downloaded and develop faster but now I can go any further until my modem works again.

Thanks for reading my post, hope you can help me.


is your sim card plugged in? and have you got a pin code in sim?

My sim card is plugged in and not all the providers need a pin code on the sim. Before the upgrade the module was working fine, I was able to make data and voice calls with At commands.

can there be a hardware shortcut or something? anything plugged in uart1?

did you check the firmware version on modem with “ati” command? if it is 663g… then you dont need to upload anything from firmware release 7.4 i think. I dont know much but i think you can reinstall firmware 663g… and nothing else. just at+wopen=4, at+wopen=3, at+wdwl for firmware, then at+wdwl for your application.

I found the problem. I looks that when I change the firmware the band was reset so the modem wasnt able to find the network. I solve it with the at+wmbs=4,1 command.


Same Problem…equal solution! at+wmbs=4,1!!!