VC 6 debug connection error to Open-AT...


#1

I am a newbie to Open-AT, so please forgive anything that I say that might offend you experts…

But, I would really appreciate some help…

I have been able to load everything, update my old Q2426 modules to the latest firmware, and via Cygwin, build the examples and run them on the module. All works just fine here.

But, when I tried to move to the VC++ 6(sp6) system, I can build the apps just fine in any mode, but when I try to run the debugger from within VC with the RTE debug version of anything, the VC system comes up with the error:
“Error 3: Open-AT application load failed. (error 126)”

From looking up the error codes in VC, these are either it can’t find the app, or it’s internals are not there…
Also, a popup shows up just before that, that says that there is no debugging data in the build…Humm, it’s turned on…

I get the same error whether or not the Target Monitoring Tool is running or not…

I have poked around in lots of files, trying to follow what is going on, and been through most of the VC setup options, but I just don’t see where the problem might be.

I also am running Visual Studio from a different drive from where I am doing this work…
Could that have anything to do with the problem?

Any ideas?
Thanks!
Kent


#2

Hi Kent,

Firstly, we’re not all experts (I’m speaking for myself here), and anyhow I firmly believe the only stupid people in this world are those who don’t ask questions when they have a problem. So ask away!

I’ve had a different problem when I tried to run OpenAT applications that were stored on a remote drive. I can’t remember the details of the problem, but I found I had to have the OpenAT project files on the same drive as the OpenAT program, this may also be true for MSVC++. Also, it’s very important that the installation of OpenAT is done AFTER installation of MSVC++. You may need to reinstall OpenAT.

Regards,
Arfy


#3

Hi Kent,

your problem is that you don’t use the correct firmware for your OpenAt environment.
E.g. if you use OpenAt 2.0 you should take 6.40… or if you use OpenAt 2.1 you should take 6.41 and so on.

In your case please flash the firmware which you can find in the OpenAt path on your installation. After that you should have no problems with your debugger.

Best regards,
skos


#4

Hello Kent,

you may ignore this one… I get it, too - but it works anyway!

Best Regards,
Jan


#5

Thanks for the replies, everyone…

I have Open-AT 3.02, the best I can tell. The target monitoring tool is version 2.7.4.0.
The firmware that I loaded into the module is 6.51.
The radio is the Q2426B.

Actually, the whole package came from Wavecom as a single CD image. All the versions came from this package.

Is this not correct?

More info:
I removed and reinstalled Visual Studio onto the same drive. Then I removed and reinstalled Open-AT and the tools.
So everything is now on the same drive. The apps are under the Cygwin main directory, so that I can build them under Cygwin.
I still get the same error.

Does anyone know what this error really means? I had assumed it was an error in the connection between VC++ and the target monitoring utility?

Here are the steps that I use.
I start the Target Monitor. I do an init and a get info command. The trace window is already open at start. Then I start the terminal emulator and verify that I get an OK for an at.
Then I build the rte version of the program under VC++.
Then I hit ‘go’.
Then the error pops up and then just returns to the non-running state of VC++.

What is supposed to happen when you hit ‘go’? I have been through all the docs, and haven’t seen that explained, but I might have missed something…

Thanks,
Kent


#6

Hi Kent,

core firmware version and OpenAT version matches, so that’s good - but I think for the Q24xx you need OpenAT 4.0 with matching core firmware…

Best Regards,
Jan


#7

Hi Kent,

I understand you that you can build your app with cygwin without problems - ok.

Please have a look to your build settings.
Here you should take the “debug” and not the “release” configuration.
(“debug” is default)

The last idea I have is that you take the 6.55 core firmware with OpenAt 3.10. Perhalps these combination works better as 6.51.

Sorry, but I don’t have another idea :cry:

Good luck,
skos


#8

Thanks Jan.

So, remote mode is broken with version 3 and the Q24xx?

The problem might end up being the hardware that I have. The modules are version 4.19.

Do you happen to know if Open-AT v4 will run on 4.19 hardware?

Thanks again,
Kent


#9

Thanks Skos.
The debug version is what is selected, in VC++.
Kent


#10

Hi Kent,

I’m sorry - I mixed it up with the Q2686 for which only OpenAT 4.0 is available… Please ignore my previous post :wink:

Best Regards,
Jan


#11

Hello!

I wonder if Akent has found answer to his problem, since i have the same problem with him too.
Please guide me to solve me this problem. thanks!