Cygwin bloomin' cygwin - Thread closed


#1

Hi.

I’m new to OpenAT. I’ve just loaded up the latest realease of OpenAt and dutifully gone through the tutorial to be confronted with the failed remote build compilation message

"c:\OpenAT\Projects\ExTests\LoadIde.bat -p wmmake -RTE
Loading Open AT IDE…
/cygdrive/c/OpenAT/IDE/IDE/1.07.01/LoadIde.sh: line 94: cmd: command not found
/cygdrive/c/OpenAT/IDE/IDE/1.07.01/LoadIde.sh: line 170: rm: command not found
Done.

Unable to load Open AT IDE
Cygwin version mismatch detected.
Please update the Cygwin configuration in the Open AT IDE Settings,
in order to use the version installed on your system rather than the Open AT IDE Embedded one."

Now I know that somewhere there is something I can change to get OpenAt working and instead of just getting on with my job, I’ll waste ages repairing an in-built, predictable failing (there’s lots of posts about this - so it’s predictable and there’s no installation notes I can find, in the documentation). The real problem is I already have an earlier version of cygwin which is used by another tool. And that tool will stop working when I fix the OpenAT issue. I know this, because I’ve been down this path before a long time ago - it was hell on wheels.

I’m just wondering, while I’m wading through the 100 or so posts in this forum, if anyone knows of any good links to articles or sites that tell you how to install or configure windows/cygwin in a way that avoids these kinds of conflicts?

Ta very much,

Steve Jag


#2

So here’s what I think the current state of play is.

I’ve been through other cygwin posts on this forum and the only solutions seem to be uninstall the other tool and re-install
OpenAT. Can’t do that. I need the other tool.

I’ve checked the OPenAT tool guide (section 8 ) which has some info on cygwin (it seems to confirm that there can only be one functioning version of cygwin per PC) and it says I should point it to the other distribution, which I’ve done - in so far as the settings tool would let me. That didn’t work. What ever it is that OpenAt expects to find there, is not there. I still get the same error message. That distribution by the way, is for another specialist application tool which is several years old - but more importantly, stable.

I’ve been to the Cygwin site and downloaded the manual which is aimed at IT software developers and talks in a language I find hard to follow. Cygwin says its setup.exe routine will sort everything out, but it looks like it just wants to install a brand new version. So I need to figure out exactly how to drive it before I press the buttons. The manual mentions environment variables and the like but it isn’t clear if this is the cygwin or windows environment.

If someones already been down this route I’d really appreciate your knowledge. Otherwise I’m looking at the expense of another PC just to run a free application and judging from the posts, even then its not guaranteed.

Regards,

Steve Jag