OpenAT (4.21.01) Project Wizard Problem


#1

I am using OpenAT(4.21.01) installed at D:\OpenAT.
For creating an application using OpenAT Project Wizard, I followed all the steps as mentioned in Section 2 of “TU_Tutorial_for_Open_AT.pdf”. I have made sure that the IDE settings are also correct.
After clicking Ok on the wizard (IDE as Eclipse), I get following errors in the dosshell:
Loading Open AT IDE…
bash.exe: warning: could not create /tmp!
./LoadIde.sh: line 94: cmd: command not found
./LoadIde.sh: line 149: /bin/mkdir: No such file or directory
Done

After that, Eclipse IDE launches with no project created. In the project directory, only a .metadata folder and a wmnew.wzrd (1KB size) file is created.
If I select Microsoft Visual C++ 6.0 as the IDE in the OpenAT Project Wizard, then following error is received:
“.dsw file not found, Please verify that the path and file name are correct.”
And no .dsw is created.

So in any case, I am not able to use the Project Wizard for creating an application.

Am I missing something?
Please help me out.


#2

That sounds like a cygwin problem. If you have other cygwin installations, try to uninstall them and re-install the OpenAT SDK. That’s how I once solved the problem…


#3

I have already uninstalled my earlier cygwin. And then again installed OpenAT. But the problem is still there.


#4

The bash errors we were facing got resolved by doing following:
The “bash.exe: warning: could not create /tmp!” and “./LoadIde.sh: line 149: /bin/mkdir: No such file or directory” errors were solved by deleting the registry entry of previously installed cygwin.

The “./LoadIde.sh: line 94: cmd: command not found” error was solved by modifying the PATH variable to include “D:\WINNT” and “D:\WINNT\system32”.