OpenAT Install Problem, wmcheck failures


#1

Hi,

For some reason my working OpenAT configuration doesn’t work any more. I can’t build an application using Visual Studio 2005 Express Edition.
My primary problem is being unable build my project after installing OpenAt, and no matter how many times I reinstall OpenAt or cygwin I cannot correct the errors given below:

I get the following error when I build in Visual Studio IDE:

------ Rebuild All started: Project: kontrol_rte, Configuration: Debug Win32 ------
Deleting intermediate and output files for project ‘kontrol_rte’, configuration ‘Debug|Win32’
Compiling…
appli.c
ApplicationManager.c
BusinessLogic.c
util.c
Generating Code…
Compiling manifest to resources…
Linking…
Creating library ./rte/vc71/Debug/kontrol_rte.lib and object ./rte/vc71/Debug/kontrol_rte.exp
Embedding manifest…
Performing Post-Build Event…
RTE executable Kernel not found in /cygdrive/C/OpenAT/Tools/CoreSW/…
Project : error PRJ0002 : Error result 1 returned from ‘C:\WINDOWS\system32\cmd.exe’.
Build log was saved at “file://c:\erdal\development\workspaces\svnwavecomprj\rte\vc71\Debug\BuildLog.htm”
kontrol_rte - 1 error(s), 0 warning(s)
------ Skipped Rebuild All: Project: kontrol, Configuration: Wismo Target Win32 ------
Project not selected to build for this solution configuration
========== Rebuild All: 0 succeeded, 1 failed, 1 skipped ==========

I uninstall OpenAT, try to manually remove all registry entries, delete cygwin but after I reinstall it, Wmcheck returns the following errors. My version is 3.10. When I am installing after an uninstall, there is an * next to SGT v1.2.11*, which says it is an already installed component. Any help will be really appreciated. I don’t want to reinstall windowsxp :open_mouth:

$ wmcheck
Current target compiler : [ERROR]
Current target memory size : [ERROR]
Current target Core Software : [ERROR]
Current IDE workspaces synchro list : [unset]
Current SGT directory : /cygdrive/C/OpenAT/Tools/SGT/v1.2.11 [OK]
Current SGT version : [ERROR]
Current SGT scripts directory : [ERROR]
Check make_lib script : [ERROR]
Current Open AT directory : /cygdrive/C/OpenAT/V310 [OK]
Current Open AT directory (for Windows) : “C:\OpenAT\V310” [OK]
Current GCC compiler directory : /cygdrive/C/OpenAT/Tools/GCC/3.0.4 [OK]
Current ARM compiler directory : [unset]
Current Add-on libraries directory : C:/OpenAT/V310/TgtGen/Add-ons [OK]
Current Tools base directory : /cygdrive/C/OpenAT/Tools [OK]
Current Core Software root directory : /cygdrive/C/OpenAT/Tools/CoreSW [OK]
Check wmnew script : /cygdrive/c/OpenAT/V310/TgtGen/WmGen/wmnew [OK]
Check wmmake script : /cygdrive/c/OpenAT/V310/TgtGen/WmGen/wmmake [OK]
Check wmsync script : /cygdrive/c/OpenAT/V310/TgtGen/WmGen/wmsync [OK]
Check wmsetup script : /cygdrive/c/OpenAT/V310/TgtGen/WmGen/wmsetup [OK]

The Open-AT environment is not correctly installed.
Please run the $WMATHOME/TgtGen/WmGen/wmsetup script or refer to the Tools Manua
l.


#2

I solved the problem by adding the SGT_DIR, SGT_VER and SGT_SCRIPT variables to the environment variables with the correct values. I reinstalled windows by the way…

I think the correct solution would be through updating cygwin’s user home directory and using cygwin scripts but I couldn’t do it due to inexperience.