Trouble running sample application


#1

Hi,

We have a problem with the very simple Hello_World example provided with Open AT V400.a03. (Wismo Quick development kit)
We’ve compiled this example using GCC according to instructions in OpenAT tutorial and then successfully downloaded it to
Q2686 Wireless CPU. However, after issuing AT+CFUN=1 and AT+WOPEN=1 commands nothing happens.
The AT command still works so the modules doesn’t seem to hang, but we never get the “Hello World” output

AT+WOPEN=2 gives
+WOPEN: 2,“AT v04.00”,“AT v04.00”

Here the complete serial output trying to run the HelloWorld example

at+wdwl
+WDWL: 0
at+cfun=1
OK

+WIND: 0

+WIND: 12,0

+WIND: 12,1
at+wopen=1
OK

+WIND: 0

+WIND: 12,0

+WIND: 12,1

+WIND: 7

AT
OK

Thanks


#2

Hi,

Try reading FAQs page:
http://www.wavecom.com/modules/movie/scenes/support/index.php?fuseAction=listFaqs&rootName=Open+AT%AE+OS%3A+APIs

Search and click the question :
“An Open-AT application runs in debug mode but not in target mode. What is the proper process to exit from debug mode?”

Maybe some other FAQs can help


#3

Hi,

Thanks for your reply but our SDK does not contain the RTE enviroment
We are also missing the RTE library, so we are unable the build a application in debug mode

So it’s unlikely that the cpu is stuck in debug mode

Having said that, If the cpu is in fact stuck in debug mode
what is the proper way to exit from debug mode without the RTE enviroment?

Thanks


#4

what is the IDE you got ? Eclipse or Visual Studio ?


#5

We use Visual Studio


#6

From FAQ:

"The proper way to exit from debug mode is:

  • Stop RTE environment.
  • Click on ‘Safe Modem’ tab given on the RTE. (This will stop the customer task running on the PC.)
  • Close TMT and serial port in Selima."

Try to run a sample program using RTE and you will know. Better contact Wavecom or distributors for missing libs.


#7

Thanks for your reply, but Like I already said we don’t have
the RTE environment

So we are unable to run a sample program using RTE

We are currently waiting for response from Wavecom and our distributor
But not a word from them yet


#8

How did you manage that?

I thought it was a standard part of the toolset - I didn’t think there was any option not to have it…?! :confused:


#9

Beats me

Everything is fully installed and the openAT Developer toolkit installer clearly states that the following is going to be installed

  • Target monitor tool
  • Serial Link Manager
  • Terminal Emulator

Should the RTE environment be mentioned here?

(in the other installer the RTE environment is also not mentioned)


#10

No.

In Visual Studion, your Solution should contain two Projects called, for example, “my_project” and “my_project_rte”

“my_project” builds the Target image using your ARM cross-compiler;

“my_project_rte” builds the Remote-Mode application using the Microsoft native compiler.

That’s all there is to it!


#11

Thanks for all the replies

We received new software from our distributor and now everything is working as it should

The demo applications are running, the RTE environment is running
So it looks like the Open AT V400.a03 software we received at first was incomplete/broken