Execut a target application


#1

I am new to wavecom open At I got the SDKQ2686 Here are the steps i went through to run a Hello_World sample in target mode

  1. Used the project wizard to create the application. (successful)
    2- Used the Cygwin command window to create compiled files ; using GCC compiler…(successful all output binary files were successfully created)
    3- Used the Hyper Terminal to download and execute the embeded application Here is what I get :

[color=green]at+wdwl
WDWL: 0

Here I started downloading the file “gcc_Hello_Word_H.wpb.dwl” using file transfer. then:

[color=green]at+cfun=1
OK

+WIND: 13

+WIND: 12,0

+WIND: 12,1

+WIND: 1

+WIND: 16

+WIND: 7

+WIND: 4

+WIND: 10,“SM”,0,“FD”,0,“ON”,0,“SN”,0,“EN”,0

+WIND: 11,“90F565D03533AA430CDFB39167F27221”,“670F3C788BB43CE1F927CD644C3D3E
EE”
at+wopen=1
OK

It looks as if nothing went wrong but i never received the "Hello World " strings…

Any idea what is missing??


#2

Hello,

Never forget that the Open AT OS and the libary must be compatible with each other!

What is the answer for the AT+WOPEN=2 command?

tom


#3

Hi mmahmoud,

Did you run the sample (or any other program) in RTE mode before?

In this case you might want to try to run the RTE application again. But do not start the program, please. Just click on “Safe Target” in the RTE window, then quit again.

Now try to run the target application again. I think it’ll work now. This usually happens if an RTE application crashes, or the debugger is stopped without quitting the applicaton properly.

Best Regards,
Jan


#4

Thank u for the quick response. Here is what i get:

[color=green]+WOPEN: 2,“AT v04.10”,“AT v04.00”

I did not use the RTE mode… Any suggessions.


#5

Thank u for the quick response. Here is what i get:

[color=green]+WOPEN: 2,“AT v04.10”,“AT v04.00”

I did not use RTE mode… Any suggessions.


#6

The response means that the core firmware is newer than the OpenAT library you compiled the program with.

You always should use the appropriate version of OpenAT to match the installed OS. Please try to compile the sample again with OpenAT 4.10 and see if it works then.

Best Regards,
Jan


#7

It is perfect now :smiley: thank u so much…
My goal is to turn this application into a self automated. I mean that the application should run automaticaly (upon power on or upon sms receival).
Can any one guide me to the documents and/or tools that will help me achieve my goal ??


#8

Hi,

if you leave it at at+wopen=1, the application will run automatically on power on.

I don’t know how you would like to run the application upon incoming SMS. I mean, certainly you could wait in AT command mode without a running application until an SMS is received and then start the application with at+wopen=1. But you would need an external controller to do that, and you would not be able to turn off the module anyway (because you wouldn’t receive SMS then…), so you might as well write the application so that it waits itself for arrival of SMS.

Best Regards,
Jan


#9

This is very smart. Thank u Jan, I do appreciate your help.