Problem with Hello_World


#1

Hello everybody!
We have a problem with the very simple Hello_World example provided with Open AT 3.10. We’ve compiled this example using GCC according to instructions in OpenAT tutorial and then successfully downloaded it to Q2406B module. However, after issuing AT+CFUN=1 and AT+WOPEN=1 commands the module hangs and stop responding to further AT commands. The green reset LED on development board start blinking every 8th second, it seems to be watchdog resetting our module due to application hangup. Every time when the LED blinks +WIND: 3 appears in the terminal window, but “Hello world” doesn’t appear at all. We’ve tried this on two modules, but got the same. Any ideas?


#2

Have you double-checked that the Default Memory Size parameter in the Open-AT Settings tool is set to “B” ?

Also the file to download in the Q2406B must be gcc_Hello_World_B.wpb.dwl (and not gcc_Hello_World_A.wpb.dwl)


#3

Thanks for your response, Jay, we found the solution. In fact, our problem was in that while struggling with ‘wmnew script error 3’ we tried to download and install Cygwin separately, not using one from the OAT 3.10 CD. Thus, GCC compiler from this fresh Cygwin couldn’t produce correct .dwl file for Q2406B. So, we uninstalled all Wavecom and Cygwin stuff and installed it again, but from OAT CD, and after that we could compile projects properly.


#4

I have read the problem you had with executing “hello_world” example provided with Open AT 3.10. So, I have the same problem. My “Hello_World” doesn’t work. LED is red and evry 10 sec. goes off and in that moment in the terminal window appears +WID: 3, but “Hello_World” doesn’t appear at all. Also my modem M1306B doesn’t accept any AT command, so I can’t stop the embaded aplication with AT+WOPEN=0, even more I can do notheing.

Please help me, if you know the way how to take the control over the modem again.


#5

I have read the problem you had and i have the same. The red led is blinking every 10 seconds. I’m using Q2501 modem and doesn’t response to further At commands.

The terminal window shows +wind:3.

How can solve this problem?

I’d appriciate your help


#6

Hi,

I am new to this and am faced with the same problem…

How do I delete the downloaded program if I cannot send at commands??

Someone please help!!

George


#7

Hi George !

  • run ctrl+i in TerminalMonitoringTool
  • BEFORE you make firmware download
  • downlod dwl.dwl file
  • download firmware
  • reset the modul ( at this point you can use at+cfun )

After that you will be able to make new upload to target.

If you do not download dwl.dwl file then you will get wopen=3 error, wopen=4 error etc.

Hope it helps !


#8

Hi everyone!

M name is Pablo, I’m from Buenos Aires, Argentina, and I’m working on Q2686 CPU with its development kit.

I had trouble downloading the .dwl file of the Hello_World app to the module, because after reset (+cfun=1), the app didn’t work and the CPU doesn’t answer any AT commands. Also, the TMT doesn’t recognize the module anymore (there is no match in baud rate). I see the led’s in the kit are blinking, looks like a continuous reset…

I tried to boot in safe mode, pressing SW304 and SW305, but nothing changes at all…

Any suggestions? Thanks!!


#9

Pablo,

check this out:
wavecom.com/modules/movie/sc … .php?t=889

I hope it helps…we have the same problem, but we could not fix it as we don’t have the dwlWin tool yet.

Pls send a reply if you find another solution!

Thanks,
Karoly