Undocumented: ADL_TRC_ Trace Levels used internally by ADL


#1

ADL generates its own, undocumented, debug TRACE output in the CUS4 element of the Target Monitoring Tool.

Exanple:

****** Traces ****** 
Type   From   Level 

Trace   CUS4   20   [ADL] tmr subs ; id 0 ; hdlr 002118A9 ; val 10 ; cycl 0 
Trace   CUS4   21   Get Mem 01061318 
Trace   CUS4   21   Rel Mem 01061318 
Trace   CUS4   23   [ADL] Gpio subs 00000200 00000200 00000400 1 : 2 
Trace   CUS4   30   SIM event 2 
Trace   CUS4   23   [ADL] Gpio Read 2 00000200 : 00000000

I can’t find these mentioned anywhere in the documentation (v3.03 or 3.12), although the Trace Level definitions are in adl_traces.h:

#define ADL_TRC_LEVEL_ERROR     20
#define ADL_TRC_LEVEL_MEMORY    21
#define ADL_TRC_LEVEL_FLASH     22
#define ADL_TRC_LEVEL_DAC       23
#define ADL_TRC_LEVEL_GPIO      23
#define ADL_TRC_LEVEL_BUS       24
#define ADL_TRC_LEVEL_FCM       25
#define ADL_TRC_LEVEL_SMS       26
#define ADL_TRC_LEVEL_CALL      27
#define ADL_TRC_LEVEL_AT        28
#define ADL_TRC_LEVEL_SAFE      29
#define ADL_TRC_LEVEL_SIM       30
#define ADL_TRC_LEVEL_PORT      30
#define ADL_TRC_LEVEL_GPRS      31
#define ADL_TRC_LEVEL_RTC       31
#define ADL_TRC_LEVEL_AD        32
#define ADL_TRC_LEVEL_GPS       32

#2

Oops - duplicate: wavecom.com/modules/movie/sc … php?t=1217

But why didn’t my search for ADL_TRC_ find that?? :angry:


#3

Several releases, and nearly a year later - and they are still not documented! :angry:

It’s not even as if this is an obsolete feature and, thus, not worth documenting - the following had been added by SDK v4.24:

#define ADL_TRC_LEVEL_IRQ       29
#define ADL_TRC_LEVEL_AUDIO     29

#define ADL_TRC_LEVEL_OSA       32

:angry: :angry: :angry:


#4

Another 18 months, and more releases, and things have just got worse! :angry:

These Trace levels are still used, but now (since v5r00?) they aren’t even listed in adl_traces.h - they are now entirely undocumented! :angry: :angry:


#5

Note that “CUS4” is now “ADL


#6

R7.4a (possibly others) now seems to use level 15 for the RTC; eg,


#7

Hiya,

Having undocumented system traces in the ADL output is a right pain.

Can we put in a feature request for these system traces to be moved to the appropriate SYSTEM level, and leave all 31 traces available for development.

And yes, I’m using nearly all the trace levels in a particularly complex application. I

ciao, Dave


#8

Absolutely! :angry:

Seconded.

Me too - that is, of course, how I discovered this undocumented and annoying feature in the first place! :angry:


#9

It seems that level 20 is also used by the Backtrace analysis.


#10

Still no change. :unamused:

Note that WIP also produces undocumented traces on ADL Level 1; eg,

See: https://forum.sierrawireless.com/t/gprs-setup-failed-8-meaning/5063/1

Also: https://forum.sierrawireless.com/t/how-to-remove-gprs-and-ftp-debug-info/2687/3

And: https://forum.sierrawireless.com/t/multiple-http-requests-every-other-one-fails/4184/7