A lot of empty traces.


#1

Okay trace is very nice think but i cant clear my trace window from "cant fing trace string" empty traces. How i can do this, because its fall and fall into my window. So i cant see any important traces, that my device send to me, may be it connected with that fact, that i used 3 wire UART connection with PC ?


#2

No, it isn’t.

They are “internal” traces for which Wavecom do not normally release the decode to customers.

Go to the ‘Trace’ menu, and select ‘Set Diagnose Levels…

Then go through the list and ensure that everything is turned off other than the ones you specifically want; which will be CUS or ADL or similar - see your Tools Manual


#3

Окау i set only ADL 1st level, other is turned off. So i think i shold get only my trace with firs level
TRACE (( 1, “________________________”));.
Or i should set CUS level on (in q64 i have CUS 1,2 and 7 levels) ?


#4

I think whether it’s called “CUS” or “ADL” is just a matter of which version(s) of tools & Open-AT you’re using…


#5

i use 2.8.9.0 version of target monitoring tool


#6

hey is anybody know how turn off empty traces like this:

1118.296 Trace DEV 1 Unable to find the string of the remote trace in the file (ID = 24969)

all DEV flags in tmt disabled, whats happend ?


#7

Hiya,

It sounds like you are using the OpenAT environment and the stand alone TMT for your development? If so, start by making sure you are using the correct Workspace File for TMT.
To load this file, open TMT, then File -> Open Workspace and navigate to the gcc\out\tmt directory in your project. If your project has compiled correctly, there should be a file here called gcc.wks. Select this file to help in mapping the trace id’s to strings.

Other than that, there are a large number of traces that are wavecom specific and will never be decoded by TMT. There’s nothing to do but ignore them. The new Target Management perspective in M2M Studio hides these system traces - but there are some other issues…

ciao, Dave