TMT unable to find the string

Hi all,

I’m developing my first application for Wavecom FSU001 (with firmware R73). I have installed IDE from a file that i received for my local Wavecom distributor called “Oasis 220”. IDE version is 1.08.02. OS version is 6.20.04.

My problem is that TMT can not match the strings from the traces that i have added. I have loaded the workspace into TMT and i have enabled CUS traces (Set Diagnose Levels).

In TMT i get only these kind of printouts:
“Trace CON 1 Unable to find the string of the remote trace in the file (ID = 14535)”

I searched the forum and found that other people seem to have similar problem:

There are some errors during the build process could this be related to the problem?

In the “Tools Manual for Open AT® IDE v1.08” i can read that the trace channel should be APP from OS V6:
“- APP: for traces sent by a single-task application”
When i use the operation “Get Information About Target” in TMT, APP is NOT available in the list of trace channels (so i selected CUS1 instead).
Could it be a problem with my firmware?

What do you recommend me to try next? All suggestions are welcome!

Best Regards

I don’t know much about Oasis 2.x, but here’s what I know from using an older IDE:

  • When running TMT, you need to open the file /gcc/out/tmt/gcc.wks (your path may be different). If you don’t load the *.wks file, you will still be able to see your TRACE strings, but some features won’t work right (like memory inspection) and you’ll see the “Unable to find the string…” messages.
  • The zip errors and warnings are harmless. I think the build script is trying to zip some files that are only available within Wavecom.
  • When you use the TRACE macro in your application, the message shows up as CUS4, checkbox 1. Be aware that the Wavecom code also logs text at that level, so you may see some messages that aren’t yours even if that’s the only level enabled.

Thanks for your response Matt!

I’m using the workspace (“my project”/gcc/out/tmt/gcc.wks) so i don’t think this is the problem. Since i’m new to Wavecom’s products i might have missed something else.

At the moment i’m trying to confirm that DEBUG_APP is set by the build system. (According to the manual it must be defined for TRACE macro to work )
I’m using Eclipse and a project generated by the Open AT project wizard. In the generated make file there is no “DEBUG_APP”.
Within Eclipse, in the “Make Targets” there seem to be only one version “Build(Target)” i.e. not separated for release and debug configurations. How can i confirm that my build is for debug configuration? Maybe i should not use the Open AT IDE? Should i download and install M2M studio?

According to the manual traces should show up as APP from OS V6 (Neither APP or CUS4 are available in the list after doing command “Get information about target” in TMT).

Best Regards

Sorry, you’ve exceeded my knowledge on the subject. I’m not even using the Wavecom IDE anymore (see viewtopic.php?f=19&t=2388). I don’t have DEBUG_APP defined and TRACE still works for me (when I use it, which is very rarely), but I’m also using FW 6.63b10 and 6.63g.

Thanks anyway!
I will keep my hope up that someone will guide me in the right direction.

I’m not completely stuck. At least i can develope my own application and download it to the target. My code size is increasing and it would be helpful to make use of the trace macro.

Best Regards

I have the same problem!

I use FW 7.3 and after i do the Get information…APP still does not show up in the list.

I think Wavecoms documentation on trace levels is really bad in explaining in what entity traces will appear. Half of it is in the ADL User Guide and the other half in the Tools Manual, which you have to dig deep in the OpenAT directory structure to find because they provide no link for it in the start menu like all the other documents.

I run a single-task application from the adl_main entry. So how should i get the TMT to show my traces?