SL8082T's Development tools


#1

I got some sl8082t modules at last,but in the OpenAT Framework 2.51.I can not find the sl8082t’s document and resource.when I download a dwl file of “hello world” sample to sl8082t, It told me that it is not ompatible. Does sl8082T need a new development tools? :unamused:


#2

Actually, Open AT Application Framework 2.51 doesn’t support SL808XT modules (yet…), even if Developer Studio 2.2.1 is ready for it (no need for another version).
You need to build your Open AT application with the appropriate Framework to be able to download it on SL8 modules.
You can grab a beta software version using this package repository: updatesite.sierrawireless.com/pa … gramsl808x
Procedure:

  • in DS, in “Available Packages” view, click “Add new repository”, and add the URL
  • Once refreshed, install the proposed Framework
  • Update your project to point on this Framework version (in “Open AT Application” property page)
  • Then build and download…

Please note that you can get SL8 related documentation on the developer site (developer.sierrawireless.com), in the resources section, just by filtering content for SL808x product.


#3

thanks! It works perfectly!


#4

Hi guys,

This link no longer works. Where can we get this, or a later equivalent, from now?


#5

Hi,
The link is working, are you using Packages Manager in Developer Studio to access it?

[attachment=0]sl808x.jpg[/attachment]


#6

Ah, oops.

Thanks for pointing that out - sorted now :slight_smile:


#7

Did anyone got the beta repository working?

I installed fresh copy of DevStudio, added repository, installed new packages (this was a pain, as installation kept failing. Could my internet connection, though).
Now I try to create new project and, when I select freshly installed firmware/framework, I get Java null pointer exception when it comes to selecting target platform. Platform selection dropdown box is empty.
Any ideas?

I tried to re-install everything twice, so do not think it is something to do with my machine.

Thanks,
Rudolf


#8

The target platform drop-down list is useful only to reuse a target platform previously saved (by you) from another project.
To get started, you should rather pick an Open AT Application Framework in the list below.

Anyway, we’re interested in getting some more information from your exception… Could you export a technical report (Help > Build Technical Report) and attach it here?
Thanks in advance.


#9

Thanks for replying. Report is attached as requested.

Can you contact me on Skype? (ID is ‘rumatech’). If need be I can give you TeamViewer access to my machine and we can try to figure it out together.

Rudolf


#10

It seems that you’re using DS 2.2.1, which is one year old now…
Could you please upgrade to 2.3.1 version? The issue should be fixed in this release.


#11

I’d love to upgrade, but can I download it?
I installed the version off Sierra Wireless site – I used full installer.
Light installer keeps timing out.
Attempt to do software update on my current version of Dev Studio keeps timing out too.
Could me ISP, though.

If I can get a full installer of 2.3.1 this would certainly help

Rudolf


#12

We’ve pushed a full installer version containing DS 2.3.1 version (other software will be downloaded only if you select them, which is not necessary):
updatesite.sierrawireless.com/in … v2-3-1.exe

To recover your packages: you don’t need to reinstall them, just copy the spm.properties file from the <2.2.1 install>\configuration directory to the <2.3.1 install>\configuration one.

To recover your projects: you could reuse the same workspace, but to keep a backup copy, it is recommended to start a new one, and import your projects (File > Import > General > Existing projects into workspace) from the old one.


#13

Thanks for that.

What I did today (before reading your post):

  1. Used different PC at different location to download existing light installer (2.2.1)
  2. Installed Dev Studio with all upgrades.
  3. Installed beta repository and got all packages from there.
    No timeouts, so it is something to do with my ISP.
    Everything worked fine and I could create the apps for SL808xT target.
    I then just copied all the files across to to my original PC and everything seem to work.

So, looks like there was (still is) an issue with my ISP where connection breaks. DevStudio installer can not correctly resulme installation and this caused problems.

Thanks again for all your help.
Rudolf


#14

Where do you get these now? I would have thought they would be a part of the normal installer by now?

Cheers