SL6087 7.5x firmware SIM problems

modules won’t read 7 from 10 sim cards.
Getting +CME ERROR: 13
On 7.47.0, 7.47.6 never had this issue.

are you using the same network provider or different?
can you share the wind indications?


Apologies for the 5 month old bump but we’re experiencing the same issue.
We have scoped VCC,RST,IO and CLK signals and firmware 7.52 just plain doesn’t work with 3V SIM Cards.
It will try to connect at 1.8V once and fail, then it will raise all 4 lines to 3V afterwards for approximately 500mS and then all 4 lines remain at 0V.

With firmware 7.46 we see normal operation of trying to connect to the 3V SIM card at 1.8V 3 times, then failing, then there is approximately a 1 second delay before attempting 3V and then proceeding to work perfectly.

Is there a known fix for this issue?

Many thanks.

Edit: I’ve added 2 pdf’s that contain images from the Oscilloscope measurements for both 7.46 Firmware and 7.52.
SL6087 R7.46.pdf (180 KB)
SL6087 R7.52.pdf (184 KB)

Hi, are there any updates for this?

I’ve tried looking for other technical support through your website, but cannot find an email address or phone number to contact you regarding this problem, all roads appear to lead to your forums.

It’s a major issue for us as we’ve just taken delivery of 50 populated PCB’s that use these modems and we’re having to downgrade the firmware on each of them to 7.46.7 in order for them to pass any sort of functional testing.

Thank you.

what is the response of the below commands?

In your case I will suggest you to contact your reseller/distributor to get more support.


Thank you for getting back to me. Here are the responses as requested. I have included them for both 1V8 and 3V SIM Cards.

Also here is the version information

I have used your distributor contact form this morning to send an email to one of the distributors we have an account with, i’m hoping to hear from them soon.

+CME ERROR: 554 is returned when the PIN 1/CHV 1 and PUK1 codes try to be entered when these codes are burned.

So I think we need to analyze more to find the root cause of this issue. So it’s a good news that you contact the reseller :slight_smile:



We have just tried a different 3V SIM card, this time we get

So, with 3V Vodafone SIM we get +CME ERROR: 554
and with 3V O2 SIM we get +CME ERROR: 10

I believe error 10 is SIM Card not inserted?

CME error: 10 indicates SIM is not inserted.

You can refer AT command guide,-d-,52/

Here you can refer the ‘SIM Insertion and Removal’ section.
Also have a look at WFM command :slight_smile:


That’s just the problem…
The SIM card is most definitely inserted, please see my first post with the oscilloscope traces of the modem trying to connect to that SIM card in particular.
We downgrade the firmware to 7.46.7 and there is no problem, but every time we receive new boards, we cannot waste time downgrading the firmware because 7.5x doesn’t work.

We need an effective solution or we will have to find a new GSM modem.

Have the design requirements changed with new firmware? Is there something we need to add to our electronics when using 7.5x firmware that wasn’t necessary with 7.46.7 and below?

I have had no response yet from your distributor.

Oh and just to remove any confusion. The 3V Vodafone SIM card mentioned earlier, is definitely NOT blocked. It works perfectly with a modem running 7.46.7 firmware. But 7.52 thinks the SIM card is blocked.

Also, in our design, we have SIM present, permanently pulled up to 1.8V whether or not a SIM card is inserted.

In your use case we have to do a deep analysis using the official support path i.e. via distributor.

Will check with the distributor on our side when we’ll have the name if they have no feedback from them…



I’m still waiting to hear from you. I’ve sent you all the information you’ve asked for but I haven’t had any response from you in over 3 weeks.
The distributor of the modems refuses to help and has told our PCB manufacturer that the modems are becoming obsolete - Is this true?


Hi Liam, How are you?
We have been experienced the same problem with some modules SL6087. Simcard Error 10
We are working with 7.52 version.

Could we go back in the version to fix the problem?
We have this file: “R7.45.5.201201230652-cus-q26RD-sl6087-01.wpk” but we do not know the procedure for do it with this file . wpk

Also we have those files:
“ExtendedATApp.dwl” “R7.47.0_sl6087.dwl” “R747_dwl.dwl”
We know do the upgrade with this kind of files .dwl

Do you know if the version 7.47 fix that problem?

Thank You so Much!!

Hi Ivan,

I’m glad to know others are having the same problems and it is not just us - it’s just unfortunate that no-one seems to be willing to help get this situation resolved.

I am not familiar with the .wpk files, however we downgraded our modems using R7.47.6_sl6087.dwl successfully and it resolved our issues - it’s just we had to do it on 50 Modems!!

Any firmware below 7.5 worked correctly for us, and we stopped getting the CME Error 10.

I hope this helps.