list of CME and CMS error


#1

Hi,

I’m looking for documentation where I can find all of the CME and CMS error for Air Prime product
Specifically I’m after what is +CME ERROR: 50 that occur after I run AT+COPS=2.
Can anybody please help me?

Cheers


#2

There is an Appendix at the end of the AT Commands manual that lists “Codes & Values”…


#3

Hi awneil, I’ve search through in both AT command reference set R7.51 and R7.52, AT extended set v7 & 8 for this error. But I haven’t found anything so far. Even ETSI GSM 07.07 ETS has no documentation on this CME error: 50
I 'm hoping someone from sierra wireless can help me on this.


#4

Hiya,

What module are you using? What country are you in?

ciao, Dave


#5

AirPrime - SL808xT and Q2698 - AT Commands Interface Guide for Firmware 7.50.A2

source.sierrawireless.com/resour … ware_7_5x/

Appendix 1 “Codes and Values” - starts on PDF page 893.

On PDF page 899 (Appendix p10):


#6

AirPrime - HL6 and HL8 Series - AT Commands Interface Guide
Apr 08, 2015 - Author: Sierra Wireless - Version 9.1 - See more at: source.sierrawireless.com/resour … pZgCc.dpuf

Page 670:


#7

Thanks for the help, awneil :smiley: . I’ve never thought searching in HL series documentation. That’s a great help!

David, I 'm using SL6087 in Australia. I have Rev 7.46 and also rev 7.51. My issue is that I cannot force the modem to deregister from network or change its mode to manual, and always given that error. But I will keep searching for answer in different section


#8

“Requested facility not subscribed” is usually associated with trying to use a service that is not provisioned; ie, something you haven’t paid for - like making a voice call on a data-only plan.

It doesn’t really seem to make much sense as a result from AT+CREG=2

:confused:

Is there something “special” about your SIM or Service Plan that it would want to prevent you from de-registering; eg, a “cell-lock” or “network-lock” of some sort :question:

Have you contacted your Service Provider?

Is there an Open-AT application running in the module?


#9

well the error comes from running AT+COPS=2. I attempted to de-register the modem from network

the SIM is possibly on special plan from Telstra (like data only SIM, I will need to check on this one), but no sim /registration lock as far as i know, since I rotate the test sim onto many different modem(both older and newer board). The SL6087 modem itself sometimes auto register the device onto Optus network, then it can hang there and then automatically de-register when it failed to attach and attempt connection onto another network, until it finds Telstra.

We have external processor that communicate to the modem via UART.
The SL6087 chip itself is embedded on a daughter PCB board that’s connected via pins to the main board.
We have two different daughter PCB models for this modem.
1 . The older one with R7.46 where the chip is mounted on Sierra blue PCB board and we mounted the blue pcb onto our own designed PCB,
2. The new one with R7.51 with the chip mounted on the 4 layer PCB designed by Sierra.

Debugging the new board bring us to two issues:

  • the new board takes much longer time to register itself to the correct network ( 5-10 minutes vs 10 s on the old one). We are trying to debug the issue and attempting manual/auto registration mode to see if we can fix it from our firmware alone, but then we have that CME error.
  • When we try to compare the behaviour on older board, we found the CME error also occurs in the same way.

I don’t think there’s an Open AT binary application running on it, since none of our engineers are coding Open AT binary for the modem. But now you mentioned it, here’s the results from running ATI and AT+WOPEN:

AT+WOPEN?
+WOPEN: 1 --> is this means there’s application running on it?

AT+WOPEN=2
+WOPEN: 2,“AT v06.51”,“AT v06.30” – > two version of software??

AT+WOPEN=7
+WOPEN: 7,12 --> application started in target model??

ATI9
ERROR --> this is very strange actually

ATI6
ERROR --> there’s something not right here

ATI3
R7.51.0.201205311751.SL6087 620780 053112 17:51

I 'll need to check with our engineer if we have any custom binary application running on it.


#10

Hiya,

There appears to be later firmware around for the SL6087 - R7.52.A1 is listed in ‘The Source’. The release notes are here. It might be worth trying the newer firmware (or at least reading the release notes) in case this is something that has been noticed and fixed.

ciao, Dave


#11

Well I can’t find the bug fix in the release notes. but I will try upgrading the firmware once the board is hacked up; current board doesn’t have the interface to do the upgrade. Thanks for that.


#12

Can you try using the same SIM in a different module/modem ?

Taking a long time to register is usually a network issue - the network taking a long time to “authenticate” the SIM.
This can especially be the case when first registering a new SIM, and/or when roaming.

Probably (one of) the most frequent flaws with “own design” PCBs is the power supply:
GSM modules (in fact, radio transmitters in general) take very large peak currents - so it needs very careful PCB design to ensure that the power lines remain clean & stable.

https://forum.sierrawireless.com/t/sl6078-development-kit-led-d601-does-not-light-up/7425/6
https://forum.sierrawireless.com/t/airprime-q2687-with-xm0110-gps-module/7373/10
https://forum.sierrawireless.com/t/sl6087-problems/5709/6
etc, …

This usually manifests as as comms not working at all but, I guess, if your design is “marginal” it could be “struggling” but getting there “eventually”…


#13

Yep it’s the same SIM used with the old module. I even tried new SIM just to make sure.

That’s an interesting reading. The engineers have recognised this issue years ago, and if I 'm not wrong, had pulsed power control in the firmware to power up the modem, although I’m not sure about the specifics.

So far, I haven’t had reply about whether or not the chip was customised with a certain binary. I will keep this topic posted of any update.


#14

More news about this matter:

We finally get a confirmation that custom app was being loaded into the modem.
The factory in China was able to get network registered normally though when testing, but for some reason the Australian network just doesn’t like our modem well.
Basically we are pushing it back to our supplier, and our developer has decided to introduce longer delay for allowing network registration to allow current modem to work. It’s at least partially happy news

Thanks for the help everyone! :smiley:


#15

What does the app do? Does that explain the issue?

Does stopping the App “fix” the issue?

Do you have the correct frequency bands configured?


#16

I 've just received reply from the engineer. We have talked back to Sierra about this and issue remains unsolved.
They cannot replicate the issue. Our boss has also stop ordering on this modem for now because the issue may remain unsolved for a long while, and we have alternative in 3G modem that we are using now. Also Australia will have its 2G network shutdown by end 2016, so we decided to make the make switch now.

About stopping the app, apparently so we can’t stop it.
As support personel, I’m at least happy that we won’t have this issue in future, and less modem that I have to deal with :smiley:


#17

Sorry I didn’t see the last post.

The app was supposedly is an enhancement of the GSM connection procedures.
I believe it was to allow auto registering when modem is powered.

I’ve never stopped the app though.

The frequency is always set on auto search.