Unable to detect SIM card on MC7304

The SIM card is definitely plugged into the device and I am wondering if it may be an issue of the modem not being in the correct mode to detect the SIM card?

I am running Ubuntu Server 16.04 and have just updated the modem to the latest firmware version and custom Telstra NVU. I am using a Telstra SIM card.

Additionally before I updated the modem I could see cdc-wdm1 and 2 listed in the ports below but now they are missing.

Here is my output from sudo mmcli -m 0:

-----------------------------
  General  |         dbus path: /org/freedesktop/ModemManager1/Modem/0
           |         device id: 498dd272bdc775771d25c1babfeb4b3433f70194
  -----------------------------
  Hardware |      manufacturer: Sierra Wireless, Incorporated
           |             model: MC7304
           | firmware revision: SWI9X15C_05.05.58.00 r27038 carmd-fwbuild1 2015/03/04 21:30:23
           |         supported: gsm-umts
           |           current: gsm-umts
           |      equipment id: 356853052002559
  -----------------------------
  System   |            device: /sys/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5.4
           |           drivers: qcserial, qmi_wwan
           |            plugin: sierra
           |      primary port: ttyUSB2
           |             ports: ttyUSB0 (qcdm), ttyUSB2 (at), wwp0s20u5u4i8 (unknown)
  -----------------------------
  Status   |             state: failed
           |     failed reason: sim-missing
           |       power state: on
           |    signal quality: 0% (cached)
  -----------------------------
  Modes    |         supported: allowed: 2g, 3g, 4g; preferred: none
           |           current: allowed: any; preferred: none
  -----------------------------
  IP       |         supported: ipv4, ipv6, ipv4v6

Here is my output of sudo nmcli device connect ttyUSB2 even though I would like to use cdc-wdm1 but now that it is missing I am using ttyUSB2 since it is the primary port now.

Error: Failed to add/activate new connection: gsm: GSM mobile broadband connection requires a 'gsm' setting

Any help or suggestions would be greatly appreciated.
Thank you.

what is the return of AT+CPIN? in AT command port?

Hi jyijyi,
Thanks for your reply,
The output of sudo mmcli -m 0 --command='AT+CPIN?' is:

error: command failed: 'GDBus.Error:org.freedesktop.ModemManager1.Error.MobileEquipment.SimNotInserted: SIM not inserted'

could this be hardware issue on SIM slot?

This is unlikely as it had been previously working on this same device a while ago. I will investigate using a different device but in the meantime, is there any other ways that I can check if the SIM card is recognised or not? For example if I unplug it and plug it back in is there any other way to tell?

is that all SIM cards behaves the same?
Or just one SIM card being tested?

I have tested multiple SIM cards, even my own personal one that I use daily on my phone but still with the same results. I have also tried to use a standard SIM card compared to a micro SIM card with the standard adapter but still with the same results. I even tried having a SIM card in both SIM card slots but no luck.

seems the SIM pin of the MC module has some problem.
what is the return of “AT+CFUN?” and “AT!PCINFO?”

sudo mmcli -m 0 --command='AT+CFUN?'

response: '+CFUN: 1'
sudo mmcli -m 0 --command='AT!PCINFO?'

response: 'State: Online
LPM force flags - W_DISABLE:0, User:0, Temp:0, Volt:0, BIOS:0, GOBIIM:0
W_DISABLE: 0
Poweroff mode: 2
LPM Persistent: 0'

seems nothing wrong…
I can only guess the SIM pin of the MC module has some problem.

Ok thank you for your help, I will investigate the hardware.

Do you also know why I would have lost my available cdc-wdm1 and 2 ports when running: sudo mmcli -m 0 after completing a firmware upgrade and updating the ModemManager package, and and idea of how I would recover them? They were previously listed there before the update.

normally these port should be available if the two RMNET interfaces are set in AT!UDUSBCOMP.

you can double check by

AT!ENTERCND="A710"
AT!UDUSBCOMP=?
AT!UDUSBCOMP?

Hi jyijyi,

Here is the output of the following commands, and also attached is the output of the ModemManager service logs which I am unsure what these errors mean and could they relate to why the modem is not detecting the SIM card perhaps? Do you have any idea based on these responses and logs?

Thank you for your help.

sudo mmcli -m 0 --command='AT!UDUSBCOMP=?'

response: '0  - reserved                                     NOT SUPPORTED
1  - DM   AT                                      SUPPORTED
2  - reserved                                     NOT SUPPORTED
3  - reserved                                     NOT SUPPORTED
4  - reserved                                     NOT SUPPORTED
5  - reserved                                     NOT SUPPORTED
6  - DM   NMEA  AT    QMI                         SUPPORTED
7  - DM   NMEA  AT    RMNET1 RMNET2 RMNET3        SUPPORTED
8  - DM   NMEA  AT    MBIM                        SUPPORTED
9  - MBIM                                         SUPPORTED
10 - NMEA MBIM                                    SUPPORTED
11 - DM   MBIM                                    SUPPORTED
12 - DM   NMEA  MBIM                              SUPPORTED
13 - Config1: comp6    Config2: comp8             NOT SUPPORTED
14 - Config1: comp6    Config2: comp9             SUPPORTED
15 - Config1: comp6    Config2: comp10            NOT SUPPORTED
16 - Config1: comp6    Config2: comp11            NOT SUPPORTED
17 - Config1: comp6    Config2: comp12            NOT SUPPORTED
18 - Config1: comp7    Config2: comp8             NOT SUPPORTED
19 - Config1: comp7    Config2: comp9             SUPPORTED
20 - Config1: comp7    Config2: comp10            NOT SUPPORTED
21 - Config1: comp7    Config2: comp11            NOT SUPPORTED
22 - Config1: comp7    Config2: comp12            NOT SUPPORTED'
sudo mmcli -m 0 --command='AT!UDUSBCOMP?'

response: '!UDUSBCOMP: 7'

Output of ModemManager service logs:

May  1 11:27:55 media-usb ModemManager[753]: <info>  [device /sys/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5.4] creating modem with plugin 'sierra' and '7' ports
May  1 11:27:56 media-usb ModemManager[753]: <warn>  [plugin/sierra] could not grab port ttyUSB1: Cannot add port 'tty/ttyUSB1', unhandled port type
May  1 11:27:56 media-usb ModemManager[753]: <info>  [base-manager] modem for device '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5.4' successfully created
May  1 11:27:56 media-usb ModemManager[753]: <warn>  [modem0] couldn't load carrier config: QMI PDC not supported
May  1 11:27:56 media-usb ModemManager[753]: <warn>  [modem0] couldn't query SIM slots: QMI protocol error (71): 'InvalidQmiCommand'
May  1 11:28:08 media-usb ModemManager[753]: <info>  [modem0] state changed (unknown -> locked)
May  1 11:28:08 media-usb ModemManager[753]: <warn>  [modem0] modem couldn't be initialized: Couldn't check unlock status: Couldn't get SIM lock status after 6 retries
May  1 11:28:08 media-usb ModemManager[753]: <info>  [modem0] state changed (locked -> failed)
May  1 11:28:08 media-usb ModemManager[753]: <warn>  [modem0] error initializing: Modem in failed state: sim-missing

No idea

Maybe you can try another mc73 module and see if it can detect your sim card

Hi jyijyi,

We tried have two separate MC7304 modems now, one with the latest firmware and one with the original manufacturers firmware, both with the same results. We have even tried using the latest Ubuntu distro, but still with the same results. I have a bad feeling that it may be one command that we are missing to send to the modem to configure it to be in the correct mode or to properly detect the SIM card.

Do you know a list of important settings/commands that we should set on the modem to ensure it operates in the correct mode, such as which “UDUSBCOMP” mode and any others you can think of? and explain what modes are good for what purpose?

Also would you be able to point me to a good guide which details how to setup one of these modems from scratch on an embedded Linux machine. I will try to set it up from scratch and see if I have missed anything.

Thank you again for you help.

What usb adaptor are you using?
You might need to check hardware signal

Btw, do you have mc74 module to verify?

Hi tmiller,

Did you ever work this out? I am trying to use the same mc7304 on a qotom q1900g4-m mobo, freebsd OS with a Telstra SIM. I am also having trouble with SIM detection. I did get it to work once when i was checking the BIOS on the mobo, didnt change anything and then booted from there, it detected and was connecting! with no issues. But unfortunately, after another reboot was undetected again. I reckon it may have something to do with a low power mode on the mc7304??

could this be hardware issue on SIM slot?
have you tried more different SIM cards?

did you check AT!CUSTOM?

1 Like

OMG, i figured out my problem… i put the antennas on the outside of my firewall casing and now it works. I had them mounted on the inside before and it wasn’t working… got confused with the “SIM not inserted” error but that was not what was really going on. facepalm