EM7455 with Verizon SIM in Ubuntu 16.04


#1

I have a computer with an EM7455 installed. I am trying to use my SIM card in the external SIM slot. My issue, it seems the module does not find the SIM card.

Instructions from the computer manufacturer say to enable the external SIM slot via the command:
AT!CUSTOM=“UIM2ENABLE”,1
ERROR

AT!UIMS=1
Ok

AT+ICCID
ERROR

AT+CPIN?
Ready

From lsusb, it returns the modem as:
Bus 001 Device 006: ID 1199:9071 Sierra Wireless, Inc.

The packages I have installed for this are:
ModemManager
lbqmi 1.16
lbmbim 1.14
minicom

The instructions from the manufacturer just said to install modemmanager and minicom, then enable the external slot, switch to the external SIM slot, and it should work. I installed lbqmi and lbmbim after reading some things online, but I am not sure what commands to try, because I am still not exactly sure what the problem may be.

From things I have tried, it seems the module does not detect the SIM card. I can confirm the SIM is locked into the slot properly, but I can’t confirm there is anything wrong with the slot connection physically.

I do not have internet on the computer I am using, so it has been a difficult and slow process to try things.

If anyone could please suggest some things to try to get the SIM card detected, I would greatly appreciate it!


#2

@jhcnh,

Try sending at!entercnd=“A710” at the beginning.

Couple of other points.

  • I don’t know what you want to do but uninstall modem manager, it really messes with the modem if you are using AT commands at all.
  • I would also use the QMI daemon (referred to as the SDK) provided by us rather than the open source one (libqmi). Plenty of people us the open source ones and it is fine but we are sure of ours and if it comes to proper support (rather than going through the forums) then we cannot help you if you use the open source one.
  • Also use our drivers (link at the bottom of the page from the link below), definitely do not use the open source ones.

https://source.sierrawireless.com/resources/airprime/software/linux-qmi-sdk-software-latest/

Regards

Matt


#3

Thank you.

I should have been more detailed, but my procedure includes:
ate1
at!entercnd=“A710”
at!usbcomp=1,1,100D
at!reset

then reboot computer and continue:
ate1
AT!CUSTOM=“UIM2ENABLE”,1 <-- This commmand fails
AT!UIMS=1

I was instructed to install modemmanager by the manufacturer. I will uninstall it and follow the steps you provided. Unfortunately, it will be a couple weeks until I am able to try these things again, but when I do I will report back. Thank you very much for the suggestions and let me know if you think of anything else.


#4

As Matt suggested, you need at!entercnd=”A710” before
AT!CUSTOM=“UIM2ENABLE”,1 <-- This commmand fails

AT!UIMS=1 will switch to the second SIM slot

Thanks,
James