Modem fails to detect SIM


#1

Hi,

I have an EM7455, which I have been using successfully on the Vodacom network in South Africa. Recently, I got some SIM’s for the Rain network, which operates on LTE Band B7 2600, to my understanding.

I tried 3 different SIM cards, and was unable to register with the network.

Worse, now when I put the original Vodacom SIM back in the modem, it also cannot register with the network!

It seems to me that the SIM or SIM card reader is the problem, as I get the following error message from the modem:

rogan@nemesis:~$ sudo qmicli -p -d /dev/cdc-wdm0 --dms-get-msisdn
error: couldn’t get MSISDN: QMI protocol error (37): ‘UimUninitialized’

That would also explain why I was unable to register with the Rain network, if the SIM could not be read.

Any suggestions as to how I can verify that this is indeed the problem?

I have removed and reinserted the SIM, and checked repeatedly that it is the right way up, etc, etc. This is on a Thinkpad P51 running Ubuntu 16.04LTS, if that makes any difference.

I have also upgraded the firmware to the latest version I could find, being SWI9X30C_02.30.01.01_Generic_002.045_001.zip

Suggestions welcome!


#2

Make sure your SIM is not PIN locked.
Check your SIM status with AT commands:

At+cpin should return READY state.
at+cpin?
+CPIN: READY

OK

at+cimi
001010123456789

OK

========= If you are getting this , then the modem is not reading the SIM:

at+cpin?
+CME ERROR: SIM not inserted

Regards,
James


#3

Thank you!

At least with the AT commands provided I could verify whether the SIM was identified or not. My original Vodacom SIM was recognised this morning when I opened my laptop. Removing that SIM and inserting the Rain SIM resulted in CME ERROR 13, SIM failure.

Doing an AT!RESET, and waiting for the modem to enumerate again allowed me to verify that the Rain SIM was now recognised, and that it was able to get my subscriber identity from the SIM.

Now the problem seems to be that I cannot access the Rain network, which operates on 2.6GHz (2600) using my EM7455 card. I can see that the network exists, but I do not seem to be able to associate with it:

AT+COPS=?

+COPS: (1,“rain”,“rain”,“65538”,7) ,(3,“MTN-SA”,“MTN”,“65510”,2),(3,“VodaCom-SA”,“Vodacom”,“65501”,7),(3,“Cell C”,“Cell C”,“65507”,7),(3,“MTN-SA”,“MTN”,“65510”,7),(3,“VodaCom-SA”,“Vodacom”,“65501”,2),(3,“Cell C”,“Cell C”,“65507”,2),(1,“655 19”,“655 19”,“65519”,7),(1,“TelkomSA”,“TelkomSA”,“65502”,7),(0,1,2,3,4),(0,1,2)

OK

at!entercnd=“A710”

OK

AT!BAND=?

Index, Name, GW Band Mask L Band Mask TDS Band Mask

00, All bands 0002000007C00000 00000100030818DF 0000000000000000

01, Europe 3G 0002000000400000 0000000000000000 0000000000000000

02, North America 3G 0000000004800000 0000000000000000 0000000000000000

06, Europe 0002000000400000 00000000000800C5 0000000000000000

07, North America 0000000004800000 000000000300185A 0000000000000000

08, WCDMA ALL 0002000007C00000 0000000000000000 0000000000000000

09, LTE ALL 0000000000000000 00000100030818DF 0000000000000000

                                               0000010000000000 - B41    

                                               0000000002000000 - B26    

                                               0000000001000000 - B25    

                                               0000000000080000 - B20    

                                               0000000000001000 - B13    

                                               0000000000000800 - B12    

                                               0000000000000080 - B8     

                                               0000000000000040 - B7     

                                               0000000000000010 - B5     

                                               0000000000000008 - B4     

                                               0000000000000004 - B3     

                                               0000000000000002 - B2     

                                               0000000000000001 - B1     

                              0002000000000000 - B8  (900)

                              0000000004000000 - B5  (850)

                              0000000002000000 - B4 (1700)

                              0000000001000000 - B3 (1700)

                              0000000000800000 - B2 (1900)

                              0000000000400000 - B1 (2100)

OK

From what I can make out, B7 is 2600 MHz? So it should work, at least in theory!

Any more suggestions I can try?

Thanks!


#4

Did you set your APN correctly?
at+cgdcont?

you can check the modem status with
at!gstatus?

can you provide the at+cimi and at!priid? output?


#5

Annoyingly, it turns out that the physical location I was in was the problem. The network claimed coverage, but perhaps in the middle of a large building is not the best place to be testing it!

It worked first time when I tried it in a different location.

Thanks for your help.