SIM Registraion Issue

I have a Dell Machine with modem support in it. The modem is MC7455B.

Usually the SIM used to connect with the network. But now, within some days, it’s not able to connect to network.

After checking the modem manager logs, I see that, the SIM is trying to register, but it’s not able to register.

Tried to understand a lot, but can’t figure out what’s the reason.

Is the SIM OK to connect network in a phone?

What is the return of the followings?

1 Like

The SIM works in phone


Manufacturer: Sierra Wireless, Incorporated
Model: MC7455B
Revision: SWI9X30C_02.28.00.00 r7500 CARMD-EV-FRMWR2 2018/02/02 23:38:13
MEID: 35907206299112 
IMEI: 359072062991126
FSN: LQ833185280110


 preferred fw version:
 preferred carrier name:  GENERIC
 preferred config name:   GENERIC_002.035_000
 current fw version: 
 current carrier name:    GENERIC
 current config name:     GENERIC_002.035_000 


+CGDCONT: 1,"IPV4V6","internet4","",0,0,0,0 

Current Time:  159192                      Temperature: 36
Reset Counter: 1                           Mode:        ONLINE 
System mode:   WCDMA                       PS state:    Not attached
WCDMA band:    WCDMA 900 
WCDMA channel: 3022
MM (CS) state: IDLE                        LIMITED SERVICE 

WCDMA L1 state:L1M_PCH_SLEEP               LAC:         139E (5022)
RRC state:   DISCONNECTED                  Cell ID:     00162C6C (1453164)
RxM RSSI C0:   -53                         RxD RSSI C0:  ---
RxM RSSI C1:    ---                        RxD RSSI C1:  ---


+CFUN: 1




!SELRAT: 11, UMTS and LTE Only



Index, Name
00, All bands



!UIMS: 0


Does it work with latest firmware?

I tried apt upgrade, but didn’t upgrade with the latest firmware.

From where can I the firmware & it’s steps of installation

You can use the exe file to upgrade in windows

Okay, in case of ubuntu 18.04. How to perform the upgrade. I’ve ubuntu 18.04

You can install the MBPL usb driver and MBPL fw download tool

I see that usb drivers are already installed. Will that work, or need to install the latest ones ?

I don’t know, you need to make some test

okay, I’ll check & get back on this

Any idea regarding the below errors:

I’m encountering this while starting the modem manager.

This error has come earlier as well.

ModemManager[5559]: [1715265427.478145] [device /sys/devices/pci0000:00/0000:00:14.0/usb1/1-4] creating modem with plugin ‘Generic’ and ‘2’ ports
ModemManager[5559]: [1715265427.485914] Could not grab port (tty/ttyXRUSB1): ‘Cannot add port ‘tty/ttyXRUSB1’, unhandled serial type’
ModemManager[5559]: [1715265427.486111] Could not grab port (tty/ttyXRUSB0): ‘Cannot add port ‘tty/ttyXRUSB0’, unhandled serial type’
ModemManager[5559]: [1715265427.486278] Modem (Generic) ‘/sys/devices/pci0000:00/0000:00:14.0/usb1/1-4’ completely disposed
ModemManager[5559]: [1715265427.486382] Couldn’t create modem for device ‘/sys/devices/pci0000:00/0000:00:14.0/usb1/1-4’: Failed to find primary AT port
ModemManager[5559]: [1715265427.486591] (ttyXRUSB0) device open count is 0 (close)
ModemManager[5559]: [1715265427.486720] (ttyXRUSB0) closing serial port…
ModemManager[5559]: [1715265427.492245] (ttyXRUSB0) serial port closed
ModemManager[5559]: [1715265427.492447] (ttyXRUSB0) forced to close port

Did you install the mbpl usb driver?

No, it was already there

then please install it

In the docs, it says, we need to disable secure boot to install the drivers.

As my machine is headless machine, it’s hard to find a way to disable the secure boot. Need to communicate with the support team.

But till then any way of installing the MBPL USB driver without disabling the secure boot.

Like, signing the drivers so that kernel can load it. Or loading the unsigned modules. Or if MBPL drivers can be pre-signed

you better ask your support team on how to install driver

Even after drivers got installed. I faced a new issue.

This didn’t came because of drivers getting installed. It was for sure earlier as well.

But, the Issue is OS can’t detect the hardware. Can this be related to the hardware’s driver

What do you see in dmesg?
What is the vid pid of your module?

The vid is 413c, product id is 81d2

In dmesg, it doesn’t show any info regarding this. It just skips it.

I have 2 same machines, I compared dmesg output of both, and found that, in the machine with problem, it just doesn’t find the hardware. No sign of it