SIM Registraion Issue

Then this is not related to driver problem, right?

Yes, even I think so… But wasn’t sure.

On many sites, they mentioned regarding, hardware failure or so.

If not driver, can it be because of the firmware ?

You can try other firmware and see if there is improvememt

I tried to update using the fwdwl tool, but as it can’t detect the modem, it’s not able to update the firmware.

Any other ways of upgrading the firmware.

Or if you know, any other forums, where I can get help regarding this issue

As said before, you can upgrade firmware in windows

Also for those machines without hardware issue, you can install the MBPL usb driver and MBPL fw download tool

Yes, I tried with one machine (uprading the firmware and MBPL usb drivers), and this fixed the issue. Well, I have few more machines, I will do the same on others, and see if SIM registration issue gets fixed.

How to upgrade firmware in windows when, it has ubuntu already installed

You can install virtual machine in ubuntu

Or you can have dual boot for windows and linux

Okay, I get it. But With virtual box, as the host is not detecting it, the virtual box, won’t be able to detect. But still, lets see, I will try.

You can switch the usb to virtual machine
E.g.

But if it is not detected, maybe it cannot be switched