EM7430 on Ubuntu 18.04.02 LTS

Hi there good day,

I would like to know if how can i setup my EM7430 on my Ubuntu 18.04.02 LTS it seems that my modem is unable to detect my SIM Card well i can confirm that the sim card is still working because managed to send a SMS using it on a GSM800L which is connected to my Raspberry Pi on Tx Rx.

I am aiming to enable the GSM Module(4G, LTE) and GPS Module of the device perhaps a keen instruction on how i can do it would be nice.

when checking on minicom AT+CPIN?
-> +CME ERROR: SIM not inserted

There is no special setup for the modem to recognize the SIM.
The modem cannot communicate with the SIM. This could be a hardware issue.

Is there anything that i can do to verify because previously it works using nmcli and mmcli when i try to install Gobi Drivers and moved the device out of the country i noticed that the device is now unable to receive WWAN connection and the device’s light indicator is always on Amber

Also tried to reformat and reinstall the drivers but still same results

Thank You.

As I wrote before I think this is a HW issue.
Try to plug in a different SIM and read the SIM status with at+CPIN?
you could try to apply some contact spray on the SIM contacts

I tried to load a sim from SG and a local sim both sim card has same results.