RV50 Radio module error

I’m using an RV50 with the firmware 4.9.3
While testing a procedure from our Engineering department, I used Putty (serial connection) with the following AT command : AT*USBBYPASS=1
According to the procedure, a new modem was supposed to be installed on my computer, but never happened and now, after a reboot, the RV50 isn’T connecting to the service provider anymore. Also, i can’t connect to the serial interface anymore.

When I boot the RV50, the signal and network LED are always flashing RED and the POWER is a solid green.

I tried to upgrade the firmware to release 4.13.0.17, but I never get the message to upgrade the radio module. After rebooting, I can’t acces the modem using the web interface (192.168.13.31:9191). The only way to get the access back is to boot in recovery mode and downgrade the firmware to 4.9.3


According to the log, there is a problem with the radio module but I can’t find a way to fix it.

Capture

P.S Sorry for my bad english/mistake, I hope you all can understand my problem and provide me with some help

Hi @frederic.labonte,
Have you tried to upgrade radio module by going to Software and firmware as the screenshot? I see that your RV50 is using MC7354 which is compatible with ATT firmware. Please try to download and upgrade module


Please share any concerns you have. Help us tick Solution if the information is useful to you guy
Thanks

I uploaded the radio module firmware, but when I try to activate it, I’m getting an error.

Hi @frederic.labonte,
Can you please post the screenshot which capture the error you got. The log file is very helpful to understand how it doesnt work
Thanks