RV50 not sending SMS


#1

I have an RV50X, NA & EMEA. I updated the firmware of the device and the radio firmware. I have an AT&T SIM card and I am completely unable to send or receive SMS messages.

At first the card did not have SMS on the plan, however I have had the service added and despite power cycling or rebooting the device it remains completely unable to send or receive text messages!

My network, power, and signal lights are all solid green. I have the white sense wire and the red power wire both connected to +24v DC and the black ground connected to ground and the green GPIO not connected to anything.

My APN is set to “broadband”
I’ve left the default values for SMS address type, SMS Address Numbering Plant, and AT+CGSMS

When I send a text using the UDP test tool, here’s the results in the log:
ALEOS_SERVICES_SMSPROC: readEth2SMSSocket: Received a message from the host
Jun 22 17:17:27 debug ALEOS_SERVICES_SMSPROC: Sending SMS msg Test message to ##########
Jun 22 17:17:27 info ALEOS_SERVICES_SMSPROC: sendMsgToQCON: Logging message Test message of size 12 to QCON
Jun 22 17:17:27 info ALEOS_SERVICES_SMSPROC: sendMsgToQCON: Response is Test message destination ########## sms size 12
Jun 22 17:17:27 debug ALEOS_SERVICES_SMSPROC: sendMsgToQCON: nextBufIndex 6
Jun 22 17:17:27 debug ALEOS_SERVICES_SMSPROC: sendMsgToQCON: Logging Message at 6
Jun 22 17:17:27 info ALEOS_SERVICES_SMSPROC: sendMsgToQCON: Sending message to QCON
Jun 22 17:17:27 info ALEOS_SERVICES_SMSPROC: sendMsgToQCON: Sent buffer index 6
Jun 22 17:17:27 debug ALEOS_SERVICES_SMSPROC: SMS Message Sent Successfully
Jun 22 17:17:27 debug ALEOS_SERVICES_SMSPROC: readEth2SMSSocket:Status of the eth2sms 0
Jun 22 17:17:27 debug

Any ideas why it’s not working?


#2

Also, for reference when I use the UDP test tool, I do not get a response back in the tool.

Also, also, here is the log after a reboot:

https://pastebin.com/bvhcHnEn


#3

Using the UDP Test tool, I’ve been able to confirm that when I send a command to send an sms message I get ACK0ACK back. However, no text is actually being sent. For a long time I wasn’t getting any response, but when I used wireshark, I found that the RV50 was ignoring the port I told it to use and was using port 59118 for some reason.

I found a document on this site:

https://source.sierrawireless.com/resources/airlink/forum_topics_and_questions/how-to-test-sending-sms-messages-with-airlink-ip-protocol/

telling how to send test messages and advising that if “The ALEOS “ACK0” message is received, but the actual SMS message is not sent. Please refer to the troubleshooting section of Sending SMS with AT command in this AirLink forum.” but I can’t find any kind of section like this on the forum. Does anyone have an update link or have any ideas why I’m being told the message is sent when it is not sending any kind of message?


#4

For those interested, the end problem was two fold and from what I can tell is specific to the ATT network.

1st, ATT put the text plan on the wrong SIM card.

2nd, the SIM card has been configured as the wrong type of device! It had been configured as a tablet (i.e. not phone), as a result the APN it connected to was “broadband”. Turns out that any device using the “broadband” APN can receive texts from the ATT service group, but cannot send or receive texts to anyone or anything else.

If you go to the WAN/Cellular tab and look at the “SIM Slot 1 Configuration” under the “Cellular” entry you need to see the following. It’s not going to work to just change the APN name. If you just change it then you won’t be able to connect to the network at all.

In the end we had to use an IMEI number from a random ATT iPhone so we could select the correct plan type. Using the IMEI of the RV50X would ONLY give us the option of using a plan that would use the “broadband” APN.