Running firmware requires 0x180 warning


#1

I have been receiving the following warning:

“Running firmware requires 0x180 as Open AT application start address, but application to be downloaded was linked at 0x260000”

I load a simple app. like “Hello World” sample and the warning subsists, so I think it is not my app. May be some settings?
I can ignore it and continue and ramdomly i get a tiemout error.
I have some problems with my app. and I will be sure that this warning is not interfering with my program.
Someone has experienced the same problem?
My firmware is 7.47 and my module is q2687 with the development board and Developer Studio is fully updated


#2

Just had this exact same error. I solved it by closing the port, and reopening it. This refreshed the status information, and the application downloaded fine!


#3

We’ve been seeing the same warning off and on since installing 2.2.1, including yesterday when trying to run the debugger. I don’t know if it’s got anything to do with some of the timout issues we’ve had with the debugger. Restarting DS seems to get rid of it (at least for a while)


#4

We’ve also noticed this behavior, which seems to be rising with DS 2.2.1 / FW 7.47 interworking.
We’ll have a look ASAP, and provide a workaround (or even maybe a patch if necessary).

FYI, since link address requirements have changed from FW 7.4X to 7.5X, we added a pre-download check to verify consistency between running FW requirement and application DWL file. This works pretty well, apparently except with FW 7.47


#5

Please note that a patch has been released to fix this bug on FW 7.47
cf. https://forum.sierrawireless.com/t/patch-for-developer-studio-2-2-1/5739/1


#6

It’s not just FW 7.47 - I’ve just had (what looks like) the same issue with 7.45.1:

https://forum.sierrawireless.com/t/ds-2-2-1-firmware-requires-0x80-as-open-at-app-start/5989/3


#7

I have seen a number of times when the status information gets “stuck” in an out-of-date state…


#8

Just happened again. Closing & re-opening the port fixes it.

DS 2.2.1