Patch for Developer Studio 2.2.1


#1

Please find attached a patch to fix some bad behaviors encountered with DS 2.2.1 and 7.51 or 7.47 Firmware versions.
You should install the patch only if you are annoyed with the following bugs:

To install the patch:

  • Go to Help > Install New Software
  • Drag’n drop the zip file in the dialog
  • Uncheck the Group items by category box
  • Select the Patch for Target Manager item
  • Click Finish and follow the steps

From there, the bugs mentioned above should be fixed.

Important note for future update
When future updates will be available for Developer Studio, please note that the patch may prevent you to handle the update correctly. It is strongly recommended to manually uninstall the patch before performing any future Developer Studio software update.


#2

Hello,

I’m trying to run a Project Sample that brings Developer Studio. The name of sample is multitasking_timmers, but when I do click in Download of Advanced Actions, and after selecting the dwl file of my project and I do click Ok, origins the error that you can see in the attached picture.

I try to solve this problem whit the Patch of this post, but I don’t have any solution.

Do you have other idea to solve my problem??

Hope your soon answer.

Pilar Alzate
Electronics Engineering Student
Universidad Pontificia Bolivariana
Medellin, Colombia


#3

Maybe your application was built for a recent SDK (2.51?), while the Firmware running on your module is older (7.4X?)
You should upgrade the FW on the module to 7.51, and it will be fine.


#4

Hello and thank you for your soon answer, but I don’t understand your suggestion. I work with the AirPrime SL6087 and with the build version of Developer Studio 2.2.1.201206182209-R9667. You said that I need to actualized the firmware to version 7.51, but i don’t understand if you talk about of software Developer Studio or file .wpk??? Can you explain me??.

Because if you talk about of version of Developer Studio, on page of Sierra Wireless have other version for to SL6087 and is v2.51 no the version 7.51. Or if you talk about of this file R7.51.0.201205311751-cus-q26-03.wpk, i don’t know to how open this file or how installed this file.

Thanks for your soon answer.

Pilar Alzate
Electronics Engineering Student
Universidad Pontificia Bolivariana
Medellin, Colombia


#5

In package manager perspective, check if Open AT Application Framework 2.51 is installed, and if not, install it.
From there, once connected to the device, in the Target Status view of the Target Management perspective, you can upgrade:

  • First the bootloader (cf. update button in the Bootloader section): choose the one associated to the 7.51 FW
  • Then the FW itself (cf. update button in the Firmware section): choose the 7.51 FW version

#6

Hello,

I follow each step and verify that the version of Open AT Framework Package (2.51.0.20120690958), and I have the version 7.51 for the Bootloader and the Firmware, but I have the same Error when do Click Download, and sometimes appears a error associated with time connection, you can see this error in the image attached.

Hope your soon answer.


#7

It’s not actually the same error. Now your running FW is sync with the SDK you use to build your Open AT app. But for any reason, in your module there is an existing Open AT application which is lying at the legacy address (0x260000, used by FW 7.4X).
As suggested by DS, you have to erase it before being able to download/use a new one at the correct address (0x2A0000, used by FW 7.5X).
From there, you should be able to run your app correctly.


#8

Thank you so much, the solution was erase the project and load the new program

Pilar Alzate
Electronics Engineering Student
Universidad Pontificia Bolivariana
Medellin, Colombia


#9

Hi pilardaniela24,

Do you erase open AT application only with

AT+WOPEN=0
AT+WOPEN=4

or using DWLWIN?


#10

What if I am annoyed (very) by a “Bad start address” warning on download, when using Firmware 7.45 :question:

forum.sierrawireless.com/viewto … 108&t=6573


#11

I mentioned FW 7.47 because it was the only version where we reproduced the issue, but the patch is agnostic regarding the FW version: the issues will be fixed on all FW 7.4X