Firmware Update Faliure - FXT009

I have a FXT009 and once I was updating the firmware to R7.52 using the Sierra Developer Studio it suddenly struck in block/byte 1033. Afterwords the the modem does not work. The the led only light up when it power up and only last for 1-2 seconds. The USB port works, but it only recognize AT command and reply “OK”. Other commands are not recognized and gives ERROR. It seems the modem is in download mode as it shows $$$$$$$$$$ signs when it is connected to the PC with USB in Hyperterminal. I tried downloading the firmware dwl using HyperTerminal (which the file size was arround 1.14 MB). But same thing happening again. It fails once it passes 1024 byte, and modem get restarted.
I think it will be possible to complete this if the file is less than 1 Mb.

Any help regarding this issue is highly appriciated

Kind Regards


I just solved the problem my self. I just download through the x-modem (not 1k-Xmodem) the Ver 7.52 dwl.dwl bootloader and afterwards the R7.52.0_fxt009.dwl from the,-d-,52_open-at-version/. It is working fine again. I restarted using AT+CFUN=1 after downloading dwl.dwl file and downloaded the R7.52.0_fxt009.dwl again restarted using AT+CFUN=1.

Hope this would help someone :smiley: :smiley: :smiley: :smiley: