FXT009 --> Firmware Update Issue

Hi all,

in order to install WIP AT, i first tried to update the firmware of my FXT009.
I searched the forum and found some post that i will need
x-modem 1k terminal

so i did all these steps and now my fxt009 does not work proberly!

This is what i get after ATI9…

` @▒Y▒▒
▒▒P▒"DWL",“V08b13”,"",“Sierra Wireless”,55344,“111611 18:03”,“dda36757”,“00010000”
T▒▒▒"FW",“FW_SRC_747_8_F4_3.Q2687RDG”,“R7.47.4.201208311102.FXT009”,“Sierra Wireless”,2221264,“083112 11:02”,“6aa633a2”,“00020000”
ݪh▒"OAT",“v1.11”,“Extended AT Application”,“Sierra Wireless”,1150680,“090412 12:06”,“d9dd8bac”,“00260000”
▒▒1▒ -“Developer Studio”,“”
▒.▒ -“Open AT OS Package”,“”
b▒,▒ -“Firmware Package”,“”
▒▒4▒ -“Internet Library Package”,“”
▒▒▒▒ -“Location Library Package”,“”
-“eCall-InBandModem Library Package”,“”
-“ExtendedATApplication Library Package”,“”

How can i solve this firmware issues?

Best regards,

Sierra Developer STudio tells me something like “target in boot loader mode”…


can anybody help me with this firmware issue?


OK i can install the new boot loader using Xmodem-1K
at+wdlw --> and then upload

after that i use at+cfun=1 to reboot the module

after that i try
at+wdwl and upload the file R7.52.0_fxt009.dwl

This works fine till ~440kb are left to transfer - then the modems cancels the upload!

GRRRRRRRRRRRRRRRRRRRRRRRRRRRRRR :imp: :imp: :imp: :imp: :imp: :imp:


Have you got hardware flow control enabled :question:

Hi Awneil,

I’m not sure if i had hardware flow control enabled, but i think yes.

Today i did these steps: (all with ClearTerminal, Hardware Flow Control, 1k-XModem)

  • downloaded the dwl.dwl file that came with R7.52. Firmware to the FXT009 using at+wdwl and after upload at+cfun=1 --> RESULT OK
  • installed the R7.47.4 firmware package (R7.47.4_fxt009.dwl) as this was the package installed as the modem was shipped to me and afer upload at+cfun=1 --> Result OK

now i get this result if I get ATI9:

P “DWL”,“V10c05”,"",“Sierra Wireless”,62640,“051513 10:45”,“a0836b50”,“00010000”
“FW”,“FW_SRC_747_8_F4_3.Q2687RDG”,“R7.47.4.201208311102.FXT009”,“Sierra Wireless”,2221264,“083
112 11:02”,“6aa633a2”,“00020000”
h “OAT”,“v1.11”,“Extended AT Application”,“Sierra Wireless”,1150680,“090412 12:06”,“d9dd8bac”,"
1 -“Developer Studio”,“”
. -“Open AT OS Package”,“”
b , -“Firmware Package”,“”
4 -“Internet Library Package”,“”
-“Location Library Package”,“”
-“eCall-InBandModem Library Package”,“”
-“ExtendedATApplication Library Package”,“”

ATI3 Response:
R7.47.4.201208311102.FXT009 2221264 083112 11:02

It seems a little bit better now, but I still get some strange characters at the beginning of lines that i didn’t get before.

Using Developer Studio, i can’t read the Target Informations and things are realy buggy. Connection to the device sometimes works or don’t works… And i can’t connect to the device with a terminal programm after i used developer studio???

It seems that something must be changed or re-installed on the modem.

Any ideas how to clean my modem so it will work normally?



first uploaded the boot loader V08b13 from Firmware R7.47 at+wdwl(“dwl.dwl”)
then uploaded the firmware at+wdwl R7.47.4.fxt009.dwl


Hi, I’ve done exactly the same thing as you and ended up with the same problem. The problem is that I can’t seem to find the R7.47 bootloader (dwl.dwl) anywhere. Could you tell me where to find it?


I also cannot upgrade to 7.52. But I was able to upgrade to 7.51 (bootloader from 7.52).

ati9 gives me mixed information (7.47 in one place and 7.51 in another - why is it so?):

“DWL”,“V10c05”,"",“Sierra Wireless”,62640,“051513 10:45”,“a0836b50”,“00010000”
“FW”,“FW_751_14.Q2687RDG”,“R7.51.0.201205311751.FXT009”,“Sierra Wireless”,620780,“053112 17:51”,“de5225b8”,“001c0000”
“MODEM”,“1.2.12”,“201205311748.FXT009”,“Sierra Wireless”,1660692,“053112 17:48”,“16b6cdaa”,“00020000”
“OAT”,“v1.11”,“Extended AT Application”,“Sierra Wireless”,1150680,“090412 12:06”,“d9dd8bac”,“00260000”
-“Developer Studio”,“”
-“Open AT OS Package”,“”
-“Firmware Package”,“”
-“Internet Library Package”,“”
-“Location Library Package”,“”
-“eCall-InBandModem Library Package”,“”
-“ExtendedATApplication Library Package”,“”

Btw, 1.47.4 can be downloaded from here (links at the end of the page):


I’ve solved my problem now.

I currently have 5 of the Sierra Wireless FXT009 modems, 1 from Linkwave, 2 from Farnell and 2 from RS. The ones from Linkwave and Farnell shipped with the version 7.47.4 firmware installed and I’ve never had any problems with them, they are used in conjunction with vwdial on Linux to make circuit-switched data (CSD) calls. The most recent ones were from RS and were shipped with older firmware, version 7.43 despite being purchased around 18 months after the other ones. I had to turn of carrier checking in wvdial to even get the modems to make a call and they seemed to randomly stop responding after several calls so I decided to investigate the firmware.

I ended up installing the Developer Studio version 1.3.5 and then using the package manager to download the old firmware. I then browsed the disk to find the files I needed:

  • dwl.dwl - C:\Program Files\Sierra Wireless\Embedded Software\com.wavecom.openat.ide.spm.fw.model.\resources\swift\dwl.dwl
  • R7.47.4_fxt009.dwl - C:\Program Files\Sierra Wireless\Embedded Software\com.wavecom.openat.ide.spm.fw.model.\resources\R7.47.4_fxt009.dwl
  • ExtendedATApplication.dwl - C:\Program Files\Sierra Wireless\Embedded Software\com.wavecom.openat.ide.spm.lib.plugin.model.ExtendedATApplication.\resources\ExtendedATApplication\bin\ExtendedATApp;ication.dwl

This is an explanation of the various files:

  • dwl.dwl - the bootloader version V08b13
  • R7.47.4_fxt009.dwl - the firmware version 4.47.4
  • ExtendedATApplication.dwl - the default factory shipped OpenAT application

I then followed the HyperTerminal 1K-Xmodem procedure to update the modem (mycusthelp.net/SIERRAWIRELESS/_c … px?aid=487). I couldn’t use the Developer Studio to do the update as the firmware running on the modem was too old.

All my modems are now running the same firmware versions and seem to be working fine now. I haven’t investigated updating to anything newer as they aren’t broke and I’m not using the programmable functionality of the modem.

For reference, here is the output of the ATI9 command before the update:

"DWL","V08b0j","","Wavecom",54744,"022410 18:01","e9be6255","00010000"
"FW","FW_SRC_743_6_F3_1.Q2687RDG","R7.43.3.201201300737.FXT009","Wavecom",2141296,"013012 07:37","daa98365","00020000"
"OAT","","","",175504,"040110 06:26","cbd05ab1","00260000"

And after:

"DWL","V08b13","","Sierra Wireless",55344,"111611 18:03","dda36757","00010000"
"FW","FW_SRC_747_8_F4_3.Q2687RDG","R7.47.4.201208311102.FXT009","Sierra Wireless",2221264,"083112 11:02","6aa633a2","00020000"
"OAT","v1.11","Extended AT Application","Sierra Wireless",1150680,"090412 12:06","d9dd8bac","00260000"
 -"Developer Studio",""
 -"Open AT OS Package",""
 -"Firmware Package",""
 -"Internet Library Package",""
 -"Location Library Package",""
 -"eCall-InBandModem Library Package",""
 -"ExtendedATApplication Library Package",""

I hope this is useful to someone.

Thanks a lot. I am absolutely new in the embedded field, so I did not know about Extended AT Application. :slight_smile:

Finally, I solved the problem in a more simple way, without reinstalling development environment. I installed bootloader from 7.52. Then I installed firmware 7.51 and Extended AT Application 1.21 (I installed Open AT Application Framework package 2.51 and found it there). After that I installed firmware 7.52 and Extended AT Application 1.3.1 (from the newest Open AT Application Framework package 2.52). Everything worked smoothly.

As far as I understand, there was a change of addresses of Extended AT Application between firmware 7.47 and 7.51. And there was a change of firmware size between 7.51 and 7.52. So, direct upgrade from 7.47 to 7.52 does not work, because new firmware intersects with old Extended AT Application.

Maybe it would have been even more easier to install Extended AT Application 1.3.1, and then firmware 7.52. :laughing: But I did not test this.