RC7611 GENERIC_PTCRB fails to update

I have tried the updates with the GENERIC_US_cellular and the ATT version of the firmware without any problem. Both times I tried, the GENERIC_PTCRB has begun to write the image, then failed with the error shown in the screenshot.

Hi @sales,

I also have tried the updates with the GENERIC_US_cellular, the AT&T and the GENERIC PTCRB version of the firmware without any problem.

Have you tried the latest driver? If not, please refer to download the latest driver using this link and try again.

If you still get errors, please describe the step-by-step you did.


I have been using the newer version build-5087 of the driver from a link on the RC7611 technical resources page: https://source.sierrawireless.com/resources/legato/drivers-for-wp75xx_wp76xx_wp8548-series-modules---latest-release/

What I did: click on the GENERIC_PTCRB executable and it connects and begins to download. Then error happens.

Hi @sales,

First of all, please provide the serial number of the device you are using.

Then try one of the following to identify where the issue come from

  1. Please do all the processes with that RC7611 again on another computer.
  2. If you have another RC7611, do all the processes you stated one more time with the first computer (the one that crashed with the first RC7611 device).


I cannot access the module factory serial number until a field test is paused in about a week. The module was purchased 2/21 so it is probably 2 years old.

  1. I don’t have another Windows computer. I am using a recent install of W10.
  2. No computer crashed. The above screenshot of the terminal view shows error codes from the installer.

Can you verify that the newer version build-5087 of the driver works with GENERIC_PTCRB?

SOLVED. The module is back from a test. I tried updating the aforementioned firmware again using a better USB cable and it programmed just fine. Someone on Youtube did a test of USB cables and found some cheaper ones are well below spec in terms of shielding and impedance.