Where is the USB driver for RC7611 FW upgrade? [SOLVED]

To update the firmware, it says, " 1. Download the latest USB driver and run the executable file."

I cannot find a USB driver anywhere in the product resources.


How about this one?


Nothing. The upgrade firmware opens a window but all the fields are empty. Press any key to continue, it quits. I don’t think that driver works for the RC series.

Windows 7 Device Manager has identified “Sierra Wireless DM Port” and “Sierra Wireless NMEA Port” so it sees the module.

how about this?

  1. download the RC FW EXE
  2. use 7zip to extract it
  3. there should be a fdt2.exe inside
  4. put the new xxx.spk inside the same folder
  5. use command prompt to update by “fdt2.exe xxx.spk”

I think you mean the .spk files under the (Android, Linux QMI SDK) section. Guess what, the links for the upgrade for ATT and T-Mobile are also .exe files, the same ones as under Windows section. That is not right and that won’t work. Why does everything have to be a struggle?


The fdt2.exe is a Windows program that still needs the missing USB driver to work.

so it does not work on your PC?
Did you try that “fdt2.exe xxx.spk”?

Yes, got the same exact result as running the exe file. Unpacking it and manually running it doesn’t change that the USB driver is still needed. BTW the .dll file must also be extracted to the same directory.

when you extract, three files should be in same folder.

BTW, I don’t see problem in running the exe: ( not sure if you have another PC to test…)


Manufacturer: Sierra Wireless, Incorporated
Model: RC7620
Revision: SWI9X07H_00.03.03.00 2bb7a4 jenkins 2020/04/15 07:57:29
IMEI: 353634110000980
FSN: 7Q9472000710AA


Are you connecting the USB through a development system or to the USB port of the module?

I used the HL development kit and connect USB port of the module to PC

I looked at the schematic and of the HL dev kit and I don’t see any application processor between the USB and the module. If you open up Windows Device manager, and look under Ports, what USB driver appears when you plug in the USB from the module?

I have those also. But the output is:

It seems similar to this,

Normally"fdt2.exe xxx.spk" can solve the problem.
Don’t know why you still have problem

I have installed swiflash on a Linux machine but the RC series is not in the supported list.
“Allowed values are: ar7 AR755X ar758x AR758X ar86 AR865X fx30_wp85 FX30(WP85XX) wp750x WP750X wp76xx WP76XX wp77xx WP77XX wp85 WP85XX”

Linux uses gobi driver for communications

I uninstalled the driver and then reinstalled it. This time there was a flag next to the Mobile Broadband Network Adapter (what “MBN adaper” means). The error was Windows couldn’t verify the digital signature. I rebooted without driver verification (press F8 while booting). Then the error was gone. I ran the original EXE file and it ran and updated fine.

I rebooted the module but the firmware date was the same 2020/04/15 07:47:29. But according to the 6.2 release notes, versions 4, 5, and 6 all have the same version number. I don’t think that is right.