R17, no eth0 in custom board

After upgrading my WP7607 module to R17, it boots normally in mangOH-Green, but when I put it in a custom board (R16.3 used to function with no issue) eth0 is not present, (ifconfig doesn’t list eth0).

It seems like an issue with low power mode on the usb host controller, btw I’ve tried executing echo NO_SLEEP > /sys/power/wake_lock

please find in the attachment two log files, one from the module when booting in mangOH-Green and the second is for the same module but in a custom board.

dev_boot.txt (87.4 KB)

custom_boot.txt (115.9 KB)

From dev_boot.txt, it has eth0, does that mean R17 is working fine with the HSIC bus to enumerate the ethernet port?

correct dev_boot.txt is from the WP7607 module on the mangOH-green, yes it’s running R17 and it has eth0 and working fine with HSIC, but once I put this module in a custom board I see this issue. WP7607 works fine with R16.3 inside the custom board.

If you just focus the case with R17, one hardware is OK , another one is not OK, did you check the hardware interface difference?

For the mandatory connection it looks the same, we even use the same LAN95xx

then that does not make sense if the hardware is the same, but only work on one hardware

I suspect there is some GPIO you need to enable in custom board

Since the same hardware with an older release worked fine, then from my side I don’t think it’s a GPIO that needs to be enabled (btw I’ve double-checked them). I find some of the kernel logs are pointing that the USB hub is in low power mode and no USB ports are detected (in my custom board)
What changed in R17 from R16.3 is the kernel, from 3.18.140 to 4.14.253 which includes few patches for smsc95xx, and a lot more for USB subsystem

Your statement seems cannot explain why it works with mangoh green board in r17

From my point of view the old releases worked perfectly fine on the same hardware (custom board), once I’ve upgraded to R17 it didn’t, which means that the changes between R16.3 and R17 is the cause of this malfunction.

then did you compare HSIC signal with the OK case and NOK case?
Is there any bus activity in NOK case?

I still think if using same FW, but one hardware is Ok, another is not OK, that is hardware problem

this was a good point, with R16.3 I see some bus activity, but when using the R17 I see a flat line with no activity at all.
btw I’m using LAN9500A and not LAN9514

then that means the ethernet is not totally the same as mangoh green board

You’re right it’s not totally the same, we’ve connected the WP76xx USB connection directly to LAN9500A, so there’s no USB Hub (USB3503) like mangoH green.


for the sake of comparison and demonstration, I’ve attached the usb signal captured on the same custom-hardware once with the R16.3:

and here for the R17, it stays at that voltage:

this cannot prove problem on HSIC bus as you should be able to see bus activity in R17 with mangoh green board