MangOH Green (WP7502) UART1 IOTO connecting issue


#1

Hello all,

I am facing problems to talk to the WP7502 (on the MangOH) via UART1 on the IOT0 connector. I have used a voltage level translator between Sprakfun 5V FTDI cable (https://www.sparkfun.com/products/9718 ) and the IOT0 connector to reduce it to 1.8V.
After opening putty and entering the port number and baud rate, the MangOH does not respond to any AT commands at all. But when using a Micro USB, the module responds to the AT commands I enter from the console!

Any idea what is going on??

Appreciate your support.


#2

Hi devuae,
Try enabling UART1 for console:
AT!MAPUART=16,1
AT!RESET

BR,
Chris


#3

Hello cchenry,

Thank you for responding. I tried your suggestion, which is setting UART1 to service #16 (Linux Console) using the AT command: AT!MAPUART=16,1
AT!RESET

Unfortunately the MangOH (WP7502 module) did not respond on the serial port. I also tried setting UART1 to service#1, which is AT command service. It also did not work. I checked on device manager, the serial FTDI cable appears…which means there is nothing wrong with the cable…

Also, the current dip switches is set to: 1,4,6=ON (the rest are off). The details of the switch is mentioned on page 35 in the following document:

Thanks

Devuae


#4

Hi Devuae,
Have you confirmed the baud rates match? You can check the baud rate of UART1 using:
stty -F /dev/ttyHSL0 -a

Also, can you confirm you have Tx and Rx connected correctly? Pin 12 labelled Tx is an input to the WP module and Pin 13 labelled Rx is an output.
BR,
Chris


#5

Hello Cchenry,

The problem was with the DIP switch no.6 (UART_CTRL). Apparently I figured out that there is a mistake in the
user guide, under “Switch and Jumper configurations”. To connect the CF3 module to IOT0, UART_CTRL should be
“OFF”, and not ON as the user guide said. Basically, the configuration is flipped.

Thanks,

Devuae