OTG doesn't work as expected on Release 17

We’ve connected an OTG cable to MangOH Red board via CF3 connector (CN801), with a usb2eth chip (uses LAN95xx) as you can see below in the photo

When using release 16.3 the usb2eth is functioning correctly, however it doesn’t work after upgrading to release 17.

here says mangoh red board does not support OTG

I remember USB OTG function should be supported in mangoh green board, you can give a try on mangoh green board.

BTW, does it work for this USB host port which is using HSIC bus?

We’ve tried the same test on the mangOH Green board, and we had the same result, with R16 the OTG works correctly when connecting to the CF3 connector (CN311), and it doesn’t work on R17.

Regarding your question about the USB host port, we are not using this in our custom board, we are interested in USB+/- connected directly to WP7607 module.

Note: on the Red board we had to shorten the post terminal strip (CN804) to provide USB_VBUS with power, as you can see here:

aren’t your custom board having the HSIC?

BTW, have you tried to just connecting a USB thumb drive instead of the ethernet board?

No we’re using the USB+/- lines directly connected to the WP7607 module.
the USB host connector works fine on both boards with R17.

i have connected the USB thumb drive in mangoh green board
it works in R16 but not in R17
I will report internally

As workaround, you might need to use R16 or route to USB host connector which is using HSIC bus.

We have test build of R17 which is for fixing USB OTG.
I have tested with USB thumb drive, it is OK to read it: