Problem connecting to new development board


#1

I got the new eval kit board. I connected with USB/Serial port connection with my laptop. I was getting AT prompt response ‘OK’ correct. Then I started downloading latest firmware 663c00_full_q2687h_W11.dwl since the firmware on the baord was older and my code was compiled with latest 4.25 code. The download was always getting stuck between 2% and 36% and evntually gets aborted. I restarted download again. Then the board was not able to for recognize the serial port. Auto detect was prompting “no match”. In the terminal I was not getting any response. I tried dwl.dwl download and I was getting “Modem not detected or port not ready” error.

I changed the CPU with another one. Initially AT commands worked fine. This time I downloaded dwl.dwl which was ok. After this I started downloading the 663c00_full_q2687h_W11.dwl version. Again it got stuck. Now I don’t get the AT command response at all.

Please help me how to recover from this.


#2

Hi jeetu,
In this case, you should download firmware with DWLwin program (with .wpb file). Remember push the BOOT pin ON, and press RESET before download (Read Help of DWLwin for more detail). Contact with Distributor for DWLwin program and firmware in case you do not have it.
ttt


#3

Thanks ttt for the response. So I downladed the DwlWin tool. But when I define the working directory (where the new firmware is located with 663c00_full_q2687h_W11.dwl file it doesn’t pickup any files Download tab. May be there does not exists .wpb file for the firmware. Only .wpb.dwl files are generated in the program I have compiled (say ftp2ftp or HelloWorld). I may be missing something very basic. Please let me know what I should be doing. The download quits after 20 attempts may be due to timeout. Let me know what I should be doing.

Thanks in advance.


#4

Hi jeetu,
If you want to download firmware with DWLwin, you must have .wpb file. You can get it from Distributor.
ttt


#5

Hi TTT,

I got new firmware .e2p files and some .wpb files from Wavecom site for 4.25 version and 663c00 firmware. The DwlWin tool was able to see the files 2 panels below wpb and e2p files. I selected them and set the right options and started the download. But nothing happened. Following Message was displayed at the end of 100s “Boot failure: cannot connect with the target. Cannot boot up the remote target: giving up”. I hope my hardware is not cooked. :frowning:

Anything am I missing?

Jeetu


#6

Hi jeetu,
Are you sure that you do following sequency:

  • Select suitable firmware and eeprom files: pro-dwl.wpb, w.e2p
  • Select suitable Serial port and Rate (115200).
  • Select CPU type: Q26
  • Switch pin BOOT on the development kit to ON position
  • Press Start button on the DWLwin program
  • Press and release the “Reset” button on the development kit
    … firmware will be downloaded to WCPU
    ttt