Firmware download fail


#1

Hi all.
Follow the documentation I’ve tried to download new firmware version (6.57f00_full_q24PL001.dwl) to my Q24.
I’ve used a Hyperterminal:
115200.8,n,1,hardware
then tried to communicate with module:
AT
OK
Next step was a download new firmware:
at+wdwl
$$$$$$$$$$$$$
I’ve chose 1K X-modem and my file 6.57f00_full_q24PL001.dwl, then click the Send button…
After few minutues without any communication “Send file…” window dissapeared and now I can’t do nothing with my module. The null modem connection is OK. Now the Q24 FLASH LED doesn’t even lights. Any resetting attempts don’t wake up my module.
Where’s the problem? Thanks in advance for any solution.


#2

Hi microelectronics,
In this case you should download firmware by dwlWin program. You can get this program and firmware (.wpb, instead of .dwl) from the distributor.
ttt


#3

Hi,
I think at the first step you should upload dwl.dwl file to your modem. It is a new downloader an it is strongly recomended to follow that step.

Mc_Urb


#4

Hi,
How can we upload the .dwl file from the un-response modem?
ttt


#5

You need to download it to the modem!


#6

Hi,

I have downloaded Wavecom Open AT SDK v3.21.exe from the site and there is no .wpb file for the firmware, only
files like 657g00_full_q24ex001.dwl with the dwl extension. Is it possible to obtain the wpb files from the wavecom the web site?

While trying to upgrade the firmware 3 Q24 Extended modules I worked on have become unresponsive ,
2 of them are responsive only to dwlwin. I am trying to create a reliable configuration to work on with M2MStudio 1.0 because
the development cycle with the previous eclipse version is very difficult and time consuming.
Which configuration of ide, firmware and tools is the best to work with Q24s currently?

Best Regards,
Erdal