DWL download error

I get the following errors while trying to download a dwl file:

EDIT: If it matters, this is what I get in the traces: “Except RTK 161”

I have tried redownloading the firmware, stopping the application and even erasing it. Any pointers on how to sort this out?

On a side note: I noticed that downloading dwl’s now takes much longer than it used to. I guess this is because after the latest updates DS performs more checks? If so, are these really necessary? Quite annoying

Please can you elaborate on your configuration?
(Module type, FW version, DS version, device connection type…)

Module type is Q2686
Firmware version is 7.45 or 7.44
I believe my developer studio is 2.2.0
Serial connection

I’m not sure what else could be of importance.

You mentioned that your issue seems related to this post: https://forum.sierrawireless.com/t/dwl-file-download-with-w32k-mode-and-developer-studio-2-1-0/5217/1
Are you also using 32K mode?

Not at the time of programming the device. The error seems similar but I suppose you could say it is unrelated.

Please can you tell us about your serial port settings?
Actually this kind of issue can occur with low speeds (e.g. 9600 bauds)
Note that it is strongly recommended to use either minimum default speed (i.e. 115200) or even better a pure USB connection for devices handling with DS.

I’m using 115200-8-none-1-none

Could you give a try with HW flow control restored?

CTS and RTS are sadly not connected in this PCB design.

Edit: Is it possible that this problem emerged after an update?

Edit: My collegue who had an older version of DS was still able to download DWL files to the device.
After updating DS however, he was no longer able.

Edit: We are still able to update the software on the devices through hyperterminal. (at+wdwl=O and sendfile wtih xmodem).

I guess this is a genuine problem with Developer Studio. Do the developers think so too?
I would love to hear your thoughts, should I wait for a solution or find an other way to continue my work?

That’s possible that all the sanity checks we added recently to secure the download are disrupted by the fact that flow control is disabled.
Even without that, it is not recommended to perform XModem download without flow control: maybe you had luck until now, but without flow control, the download should fail if the bootloader’s buffer become overflowed (it can’t say stop!!).
In your future PCB designs, you should consider wiring a full UART (or at least the flow control; or even better: USB port!) for debug purpose.

Anyway, support of a “degraded mode” (without flow control) has already been requested before (cf viewtopic.php?f=108&t=5756&start=0)
We’ll have a look, but we probably won’t get many more than just AT commands support.

Thank you for enlighting me. The RTS and CTS lines will certainly be connected in our new design.
Up untill last week I was able to enjoy developers studio’s target view for reading traces and practically everything else.

We have rarely had problems with downloading though. Can I get my hands on an older version of DS perhaps?

Or could I perhaps disable a few of these recently added sanity checks? On my own risk :wink:

Edit: I short circuited RTS and CTS, and that got it to work with hardware flow controle enabled in DS. I know its bad practice, but this will have to do for now.

Unfortunately the checks can’t be disabled (it will be probably a part of the solution in a future version).
You can still get DS 2.1.1 by getting the Open AT Framework 2.37 full installer. For older versions, you should contact your distributor.

I have to apologize, I was too quick when I said this was solved.

I have still not been able to program any modem. I am now using the Q2686 development board, hardware flow control enabled and I get the same error.

EDIT: I have reprogrammed the firmware with DWLWin, afterwards I’m still not able to download any application through DS.

Whats this ATI9 command? A quick google search and a search through a few datasheets didnt find me anything.

Clearly sounds strange…
Can you build a technical report (Help > Build Technical Report) and attach it here?
ATI9 command is a proprietary command allowing DS to know all details about embedded pieces of software in the module.

I have uninstalled the sierra wireless software.
I downloaded DWL win.
Put a brand new Q2686RD modem on a development board.
Downloaded latest firmware 7.47 from the website.

Tried downloading, boot pin active, click start, press reset on the board.
Downloading installer
Then DWLWin stops because it cannot establish connection with the CPU.
What could be wrong here? Perhapos its because I’m missing a driver?

Edit: I am downloading the latest DS as I write this, I hope this will fix all my problems.

I have reinstalled all the sierra wireless software.
When I use PuTTY to communicate with my modem (115200 no flow control) I can execute the ATI1 to ATI9 commands sucessfully.
R7.45.1 is the firmware on the modem

When I try to connect to it through developer studio I get the following error:

Serial and IMEI number are then filled in in the view.

When I hit refresh, I also get a timeout error, this time a bit more info of the view is filled in : Firmware and bootload version.

Still unable to download an application to it

I would also like to repeat that I was unable to download the firmware using DWLwin to a module that was mounted on the development board for the Q2687

Guess that all your troubles are coming from the fact that you didn’t wired the flow control…

You could certainly be right daav, but that doesnt change the fact that I have been able to program these devices for the past year. Untill now …
As I said, in our next hardware design we will definitely wire RTS/CTS, but the devices that are currently being used by our customers, who sometimes need an update just don’t have this.

I can’t get it to work, I have tried an older version of Developer Studio (2.1.1 If i remember well).

I get a Java.lang.NullPointerException when I try to make that technical report btw.

Thank you for your responses though daav, I really appreciate it because at this moment I’m stuck and have to figure this out on my own.

Besides! I have mounted a CPU on the Q26 development kit’s board. So the RTS and CTS IS connected in this case, still it doesnt work.
I get a timeout Error.

Concerning the NPE, please can you zip and attach here your DS workspace log?
(.log file located in your /.metadata folder)
Concerning the timeout you’re getting even when flow control is wired, I have some questions:

  • is the Open AT application started?
  • if yes, is it somehow performing some heavy processing which could explain why the module could answer slowly to DS requests?