Demo board / connection problem


#1

I downloaded my new program version yesterday and try it on my demo board. The program was working on the d.b. Today i want to continue my work but the demo board/connection is making reset/connect all the time

+WIND: 1
+WIND: 7

+WIND: 3
+WIND: 13

and i can’t do anything!.

In the target versions i get notice : Archive not valid or not found
Stack version: ţď|hó

In the trace ( among the others ) i get:
23 [ADL] Gpio Single Write 0 : -2
1 Current OAT Task index : 0
ARM Data Abort at 000ABDC8, Current Task 0x1B

What should i do? Should i delete whole target app? How?
Hardware reset and boot are not working.

Emil


#2

After i set ctrl+i in the tmt i can make the transfer but now i have totaly the same situation like this:

wavecom.com/modules/movie/sc … hlight=532

Any idea ?


#3

and the oscar goes to… :smiley:

  • run ctrl+i in TMT
  • BEFORE you make firmware download
  • downlod dwl.dwl file
  • download firmware
  • reset

If you do not download dwl.dwl file then you will get wopen=3 error, wopen=4 error etc.


#4

Dont know what to say accept … what’s going on!?

Demo board : glyn EVBQ26XX
Modul: q2686H

I downloaded the code, that i have tested and used min. 10 times before,to the demo board and now i have this situation:

Program is downloaded to target without errors.
I make init and reset in the TMT and the target starts to blink ( gsm and one switch LED ). This blink is running constantly and the target is making reset each second.

I can not run any command and i can not make download.
I try with dwlWinTool but as replay i get:

Hardware reset and boot are not working.
Is there other way to erase the flash ?


#5

Hello enad,

Strange if you didn’t change anything in your code. Did you use the software update feature implemented in the TMT? When i tried it was painfully slow and the status bar was quite funny as the download progressed so i suggest hyperterminal or jan’s nice program. see here for more info:

wavecom.com/modules/movie/sc … .php?t=995

I think the only way is Dwlwin, and it should recover your module.
Did you use the right DwlWin version? Did you pressed the boot button in good time?

Best Regards,

tom


#6

Yes, but this is not the problem ( my epinion ). The code was compiled without errors and warnings and the download was success.
The same code is working for some time now and i have download it ( before i have used TMT ) with ttwin. There was no crc or other errors.

Yes, and it did not work. The version is 4011. Then i have plugged the USB cable (by the way, serial cable is checked and OK ) and unplugged the serial cable. After computer and demo board restart i was able to pass the gcc_Hello_world.wpb file to the board.
Then i have repeated the proccess with serial cable. It was OK and as result i get:

Erase: all checked
RAM size: 1024 Ko
Flash size: 4096 Ko
Flash type: ST 32Mib M58WR
Process successful
Download completed on Wednesday, March 28, 2007 12:25:56

I restarted the board manualy ( per switch ), but its all the same.
GSM and switch LED are lighting and there is no way to run some command or to make download ( i get error: modem not detected or the port not ready ) but the TMT is showing connection.

I think that this must be hardware problem (maybe elec. discharge ) ?
Anyway, if you have idea how to solve this, please let me know !


#7

I am having similar problem. I got the new eval kit board. I connected with USB/Serial port connection with my laptop. I was getting AT prompt response ‘OK’ correct. Then I started downloading latest firmware 663c00_full_q2687h_W11.dwl. The download got stuck at 36% and evntually aborted. I restarted downlowd again. Then the board was not able to for recognize the serial port. Auto detect was prompting “no match”. In the terminal I was not getting any response. I tried dwl.dwl download and I was getting “Modem not detected or port not ready” error.

Please help me how to recover from this.

Thanks
Jeetu


#8

hello jeetu,

Forget that awkward feature of the TMT. ( No comment ) Use AT commands(+WDWL) and a terminal program with 1k-xmodem instead.

I think there is a great chance to revive your module with DwlWin.

Cheers,
tom