My module doesn't respond


#1

Hi,

I’ve tried to download my app to the module through the AT+WDWL command and it always hang up in the middle of the transfer and HyperTerm says “Transfer cancelled by remote user” and the module said “END OF DOWNLOAD”. So since it was impossible to finish the download properly I tried to delete the object through AT+WDWL=4 and AT+WDWL=3 but it didn’t work (got ERROR response). I was mistaken and executed AT+WDWL=1 and the app tried to start but now the module is ‘dead’.
Does anyone know how could i recover the module so that it answers again AT commands without reflashing it (DLWin or so) ?
Best regards

Daniel


#2

I fear that the only method to wake your modem is the dwlwin procedure.

We discussed the wdwl method here:

http://wavecom.profileo.com/modules/movie/scenes/forums/viewtopic.php?t=87

best regards


#3

Hi,

ah ok nice thread , i will try to follow those hints in the future. Thanks tomalex.

best regards,
Daniel


#4

Hi again,
I’ve got the DWLWin but i lost the instructions to use my ‘self-made’ cable to reflash it. I’ve asked to my distributor and told me that i was going to get it through e-mail but this was yesterday and they are so slow…
Could anyone indicate me the sequence . I’ve got both BOOT pin and Reset with a button tied to ground when pressed. I push the start button on DWLWin but cannot find the right sequence?

do i have to download pro-dwl.wpb, w.e2p, and q2406b.e2p? They are all selected in my dwlwin.

Thanks
best regards,
daniel


#5

Hello Daniel,

Take a look in my last post in this thread:
http://wavecom.profileo.com/modules/movie/scenes/forums/viewtopic.php?t=70

The only important thing for DwlWin to work is that you connect the BOOT pin to ground during power ON, then its possible to connect via DwlWin

Yes, all of them should be downloaded.

/Snoooze


#6

hi
Thanks for the quick reply. I’m trying to power on the module with the button pressed which makes BOOT pin tied to GND and then try to Start the download from DWLWin but still not working… it keeps on ‘trying to boot CPU’.

10 mins later:

Ok, i was wrong connecting BOOT pin to pin #5 . GND is pin #9 in the 15pin connector. Now I downloaded it with DWLWin but can’t access to the module trhough AT commands, the red led in Fastrack is not lighting and the Terminal Emulator Auto detect doesn’t find the module :frowning:

best regards,
Daniel


#7

Could it be that there’s something else wrong in your “self-made” cable?
Or maybe you’re using another cable when sending AT-commands…

If the download is successful, then its seems like the module is running and that the serial interface is working but on the other hand you say that the unit does not respond at all…
I don’t really know what could be wrong except that there are some points that could be doublechecked:
:open_mouth: Is it right software for your module?
:open_mouth: Is the cable fully working (do you have needed signals (RTS/DTR etc…)) have you tried with another serial cable?
:open_mouth: I know this is really basic but I have to ask: do you have the right serial speed and format (the default values are back after downloading)?
:open_mouth: Maybe Terminal/comport problem

/Snoooze


#8

Hi,

now i just tried with 3.3.9.1 version of DWLWin and it worked, I also changed my firmware for another one which included “58_custo_AT.CUS” file and now it’s working!

Big big thanks for your help

Best regards,
Daniel