OPEN AT IDE: msvcp71.DLL MISSING


#1

Hello:
I have installed the OPEN Software AT Suit in my new computer, however, when I try to ejecute the Open Software AT IDE, It doesn`t execute because the MSVCP71.dll is mising. Any help will be welcome.
Best regards:
Alberto Martinez


#2

Hi Alberto,

I haven’t seen this problem yet… Which version of OpenAT did you install?

Best Regards,
Jan


#3

The name is “Open AT”, and it’s suite rather than suit, but that’s by the way…

What exactly do you mean by that?

What version of Open AT do you have?

As far as I know, there is no such thing as an “Open AT IDE” - you either use Microsoft Visual Studio, or Eclipse, and you need to obtain & install MSVS or Eclipse separately

Sounds like something to do with Microsoft Visual C++ (MSVC)…?


#4

Not everybody is a native english speaker here, so give him a break…

Best Regards,
Jan


#5

Sure - hence just “by the way”


#6

The problem is that Wavecom have compiled their stuff with VS 2k3 and not linked everything from the C/C++ runtime into their binaries, and instead rely on the dll’s being present on the system.

I believe there’s no problem with this on Windows XP, but on Windows 2000 this is a problem, that can easily be solved by just copying the relevant files from a newer OS install.


#7

Looks like the shared DLL isn’t being shipped with the installation. This shouldn’t be a problem for the VC2003 users out there but is a problem if you are using Eclipse and msvcp71.dll isn’t in your path already.

I found the DLL was installed by a few other application on my system in their install directory. I moved the DLL to a directory in the system path (C:\Windows\System32) and everything worked fine.