Old TCP/IP lib on newer firmwares


#1

Hello everyone, i need some seriously help please.

I have a big (really big) program written to run with the old 6.51 firmwares of Wavecom Q2406B and TCP/IP v3.02 (old TCP lib), the whole program is working perfectly.

My problem is that i can’t find these old modules for sale anymore.

So my question is, are there anyways i can use the old TCP/IP v3.02 lib on newer firmwares like 6.57 ? Or can i downgrade the firmware of these newer modules to 6.51 (or other) ?

Please don’t tell me i’ll have to rewrite the whole program…

Are there any step by step guide on how to make the changes ?

Thank’s everybody


#2

Hello Bruno,

I am afraid, if you want to use new firmware like OS 6.57 you have to change to WIP. I am not sure, but there should be some guide how to change from edlib to wiplib and from edsoft to wipsoft. Please, ask you distributor for info and you can use your old Q2406B with the new 6.57 firmware.

if you want to “downgrade” the new Q24+ modules to use older firmware (which are compatible with edlib), that is not possible.

Cheers,
tom


#3

If you want to stay with edlib and your current code, I recommend at least upgrading to 3.03 (6.51a).

Some AT-commands, when called from the application with adl_atCmdCreate causes the module to reboot with 6.51.
One such command is AT+CCED=0,1.


#4

Ok Tobias, thank you. But this 6.51a runs on Q24 newer modules ?

Its unacceptable that i’ll have to migrate a code that have almost 21.378 lines, yes, it’s almost 800 kb of source code, because i cant find old modules to buy anymore, i can’t believe wavecom done it this way.

There must be some kind of adaptation that i can do on newer Q24 Series modules to make them work with the old TCP 3.02 LIB ???

Is the limitation that doesn’t let Q24 newer modules to accept old (6.51) firmwares known ?

I mean, they use the same ARM processor, have the same memory size and etc.

Thank’s


#5

Anyone tried uploading the 6.51 firmware on Q24 Plus module ?

What happens ?

Thank’s


#6

I tried…the module is not responding …as expected :laughing:


#7

Of course it won’t run on the new gen Q24 modules.
You’ll just have to rewrite the relevant parts to use WIP instead.
21k lines is not a lot, and with a good program structure, you shouldn’t have any problems going WIP instead.


#8

I copied the old TCP lib folder to the new openat plugins folder and “adapted” it to look like the WIP library folder so it now appear on the OPEN AT 3.19 PROJECT WIZARD.

i managed to compile the source code with the edlib on the newer firmware 6.57 and openat 3.19,

the program runs, connect to the GPRS and get an IP,

but when i try to send the data thru TCP i get an error -63 ED_ERR_ID_INACTIVE (The service represented by the id is currently inactive.")